Topic "how to disable "lookup user groups" via command line"

Author Message



i know it's been asked before but i got no answer.
is there a way to run the following without failing on the errors:

C:\Program Files\WinSCP> scp://root:mypassword@HostIP:22 /script=c:\myscript.txt
Automatic actions are disabled when URL address is provided on command-line.
Searching for host...
Connecting to host...
Using username "root".
Authenticating with pre-entered password.
Starting the session...
Reading remote directory...
Error getting name of current remote directory.
Command 'pwd'
failed with return code 0 and error message
: groups: not found.
Session started.
Active session: [1] root@HostIP
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24759
Location: Prague, Czechia
Please read FAQ

Though I do not think your problem is related to ": groups: not found.". It's more likely releated to: "Automatic actions are disabled when URL address is provided on command-line."

Instead of "scp://root:mypassword@HostIP:22" on command line, you should do "open scp://root:mypassword@HostIP:22" from your script file.
Martin Prikryl

You can post new topics in this forum

Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License