Topic "winscp did not write a logging file"

Author Message
zeus_12345
[View user's profile]

Joined: 2012-05-24
Posts: 5
Hi,
We have a database which creates application calls in this way:
WinSCP.exe ftp://{UserNameLocal}:{PasswordLocal}@{VPN_ADDRESS} /passive /log="{LOGPATH}{YEAR}_{MONTH}\{DAY}_{HOUR}_{MINUTE}_{SECOND}_{DEVICE_ID}_{WIN_USERNAME}.log"

but winscp did not write a logfile. Since we have to log all remote activities, we would need this feature. With ssh the log is working.

I tested /xmllog and /log. I get only the hint, that automatic actions not run if run as commandline
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
What's is the purpose of the call? Just to start WinSCP for interactive use? Or do you add some more parameters like /command to automate some operation?
_________________
Martin Prikryl
zeus_12345
[View user's profile]

Joined: 2012-05-24
Posts: 5
prikryl wrote:
What's is the purpose of the call? Just to start WinSCP for interactive use? Or do you add some more parameters like /command to automate some operation?

the purpose is to start WinSCP for interactive use, the user should not have to enter a logfile or user/password , ftp/scp and the IP
example
WinSCP.exe ftp://user:password@10.10.10.10 /passive /log="d:\connectionlogs\10.10.10.10_2012_10_02_winscp.log"
because we have to save our logfiles.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
You can work around that by replacing ftp:// prefix with command line parameter /RawSettings FSProtocol=5

WinSCP.exe user:password@10.10.10.10 /RawSettings FSProtocol=5
/passive /log="d:\connectionlogs\10.10.10.10_2012_10_02_winscp.log
_________________
Martin Prikryl
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Request for better solution has been added to the tracker:
http://winscp.net/tracker/show_bug.cgi?id=916
_________________
Martin Prikryl
Guest




prikryl wrote:
You can work around that by replacing ftp:// prefix with command line parameter /RawSettings FSProtocol=5

WinSCP.exe user:password@10.10.10.10 /RawSettings FSProtocol=5
/passive /log="d:\connectionlogs\10.10.10.10_2012_10_02_winscp.log


thanks for the workaround with
WinSCP.exe user:password@10.55.35.46 /RawSettings FSProtocol=5 PortNumber=21 /passive /log="logfile"
it works.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License