Topic "Bug 5.2.5 latest build - New Session focus in Sites list"

Author Message
Pathduck
[View user's profile]
Donor
Joined: 2012-05-29
Posts: 61
Location: Oslo
Hey,
I've noticed in the latest 5.2.5 builds that sometimes when I open the New session dialog the last opened site is not focused correctly. Usually it is opened to set focus on the last opened in the center of the dialog, but now the focused site is outside the window so I can't see it.

Is this something being worked on, or a known bug?

I'll provide screenshot if necessary.

cheers,
Stian
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
I haven't seen the problem.
Not sure if screenshot helps.
I would rather need to know how to reproduce it.
Does it happen on initial Login dialog too or only when you are opening an additional session?
I have sent you the latest build.
_________________
Martin Prikryl
Pathduck
[View user's profile]
Donor
Joined: 2012-05-29
Posts: 61
Location: Oslo
Hello Martin,

I think this is reproducible if:
- You have a long list of sessions (I have a folder of 20+ session/sites.
- You have a small window of sessions (it can be scaled)

1. select a session near to bottom of long list, log in
2. open session window (Ctrl+N)
3. Note that last focused session is not centered, and is outside of the visible part of list

Note, if session window is larger, it will be visible but will not be centered in the window.

EDIT: I already have today's nightly build, 20131011r Wink
Also I have tried with 5.2.2 - 3365. With this the session is focused on the bottom of the window, even with a small window.

-p
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
I cannot reproduce this. Can you please attach few screenshots documenting this?
Pathduck
[View user's profile]
Donor
Joined: 2012-05-29
Posts: 61
Location: Oslo
Hello Martin!

Thanks for coming back to this - it is definitely not a huge issue, but it would be nice if it would not follow into the final release Smile

This is with 5.2.5 build 3657.

I attach three screenshots.

1. Startup: This is how the dialog shows when I start it up. As you can see the last opened site is focused but is not centered in the dialog.



2. Newsession: After logging in to the server and opening the New Session window. As you can see the focus is *outside* the visible area.



3. Newsession-largerwindow: Opening new session with a larger window - the last session is focused but it is also not centered.


[/img]
winscp-newsession-largerwindow.png (73.19 KB)

Description: (none)

winscp-newsession-largerwindow.png

winscp-newsession.png (52.28 KB)

Description: (none)

winscp-newsession.png

winscp-startup.png (56.22 KB)

Description: (none)

winscp-startup.png

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
I've tried it even with your two-level folder structure. No luck. What version of Windows are you using?

Also, do you really have an icon on Login button corrupted as can be seen on the screenshots?
_________________
Martin Prikryl
Pathduck
[View user's profile]
Donor
Joined: 2012-05-29
Posts: 61
Location: Oslo
So for you the last opened session is selected and centered in the list?
Possibly there are some strange goings on with Citrix, even if I manage to repro locally as well.
I will try with RDP and see if it helps.

Yes, the button is corrupted - not sure why, possibly this is because using Citrix, because the same icon is fine opening locally. Also, when using the Login drop-down button the icon is fine (along with "Open in putty"...

Oh yes, OS... it's Windows Server 2008 R2 Standard, 6.1.7601 SP1.
Running on VMWare, x64, Intel Xeon CPU E5-2670.
Norwegian language settings.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Pathduck wrote:
So for you the last opened session is selected and centered in the list?
Possibly there are some strange goings on with Citrix, even if I manage to repro locally as well.

I was able to reproduce it finally. Fixed. Will send you new dev version.

Quote:
Yes, the button is corrupted - not sure why, possibly this is because using Citrix, because the same icon is fine opening locally. Also, when using the Login drop-down button the icon is fine (along with "Open in putty"...

Oh yes, OS... it's Windows Server 2008 R2 Standard, 6.1.7601 SP1.
Running on VMWare, x64, Intel Xeon CPU E5-2670.
Norwegian language settings.

Ok, it was absence of themes on Windows 2008. Fixed too.

Thanks!
Pathduck
[View user's profile]
Donor
Joined: 2012-05-29
Posts: 61
Location: Oslo
Sounds great Martin - send me a build and I'd be happy to test it. Possibly you already sent but it got lost?
EDIT: Downloaded nightly; icon is OK and focus is much better (although not always centered - I can live with it)

Thanks Martin!
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License