Topic "5.2.5 Internal editor issue"

Author Message
User007

Guest


On editing files with internal editors the ^^^#!/ksh sequence appeared before the first symbol. This sequense isn't visible in WinSCP internal editor, just in vi, etc.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
It looks like UTF-8 BOM.
I suppose you have set UTF-8 encoding as default for internal editor, right?

You can configure WinSCP to drop the BOM on upload (Remove BOM and EOF marks option):
http://winscp.net/eng/docs/ui_transfer_custom
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
This issue has been added to the tracker:
http://winscp.net/tracker/show_bug.cgi?id=1081
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License