Topic "No links created or not visible"

Author Message
wdburgdorf
[View user's profile]
Donor
Joined: 2014-05-25
Posts: 7
Hi,

I just tried to create links, but after creation, they don't show up.
When trying to create the same link twice, I get an error message, though:

Code:
General failure (server should provide error description).
Error code: 4
Error message from server (en-US): File already exists


WinSCP 5.5.2 / 4130
FTP, shared hosting, no root access.

I did read the manual about this ...
I tried various combinations of files and subdirectories, with and without initial slash.

Thanks for your help!

Regards,
Ralf.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
Thanks for your report.
Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
wdburgdorf
[View user's profile]
Donor
Joined: 2014-05-25
Posts: 7
Hi prikryl,
Thanks for your answer. I installed the latest version, 5.5.3-4214 and repeated linktesting with logging on, set to "normal". I removed the file listings from the log. Please find it attached.
log - creating link.txt (1.61 KB) [Download]

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
File listing is what I wanted to see. Can you please attach a complete log file showing session opening, symlink creation and subsequent directory listing?
_________________
Martin Prikryl
wdburgdorf
[View user's profile]
Donor
Joined: 2014-05-25
Posts: 7
E-Mail sent.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
I have filed two related bugs with ProFTPD/mod_sftp (the SFTP server you are using):

Reversed order of SSH_FXP_SYMLINK arguments:
http://bugs.proftpd.org/show_bug.cgi?id=4080

Not possible to create relative symlinks with SFTP:
http://bugs.proftpd.org/show_bug.cgi?id=4081

I have also changed WinSCP to workaround the first bug automatically:
http://winscp.net/tracker/show_bug.cgi?id=1185
davidmartin123
[View user's profile]

Joined: 2014-06-25
Posts: 5
Location: London, UK
prikryl wrote:
Thanks for your report.
Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

I was also facing the same problem but having implemented your advise, I got out of the mess.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License