Topic "Winscp messes up files/folders with Norwegian characters"

Author Message
[View user's profile]

Joined: 2014-11-13
Posts: 1
Hi all. I keep a backup of my music collection on a NAS having recently transferred it from a Windows server with winscp. However, any folders and files with Norwegian characters substitutes these characters with an underscore on the NAS, and the file/folder can't be opened if I mount the NAS on my Linux desktop or if I view it over ssh (also can't move/rename folders/files). If I use Winscp to browse the folders everything is fine, but only if the session option "UTF-8 encoding for filenames is set to off or auto. If I set it to on directory listing fails on any folders with files or directories containing the Norwegian characters.

Does anyone know what charset Winscp uses if it's not forced to use UTF-8?
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24736
Location: Prague, Czechia
When UTF-8 is off, WinSCP uses the local ANSI encoding for remote files.

It looks like you actually need to use UTF-8 all the time, even for the initial upload of the files.

What protocol are you using? Can you attach a full log file showing connection to the server? So I can see if the server can be identified somehow to make WinSCP use UTF-8.
What version of WinSCP are you using?
Martin Prikryl

You can post new topics in this forum

Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License