Topic "A few Issues and Error: Class TAnimate not found"

Author Message
mjklemm
[View user's profile]

Joined: 2015-04-15
Posts: 3
Location: Germany
Dear all,

First issue I'm facing from time to time, is that WinSCP stops working and present the error message "Class TAnimate not found". After clicking away the error message the right panel of the command view is gone and WinSCP has to be restarted. Please see the attached PNG for a screenshort.

The second issue is that I have a few workspace that I'm using to connect to my machines in one go. However, I cannot manage to keep the workspace from being saved when exiting WinSCP. If i click OK in the "Workspace 'XXX' will be saved" dialog, then some machine might be gone from the workspace. Checking "Never ask me again" also seems not right, because that raises the impression that the dialog will be gone, but the workspace will be saved. Am I doing something wrong here or is there an issue (or feature request)?

Third, it seems that when "Transfer each file individually" is checked in the preferences, then you cannot confirm transfers using "Yes to all", "No to all", etc. It would be great if WinSCP could remember which files had been dropped and then takes an effect of the decision for all of the dropped files (or if need be for all files in the queue that would be waiting for a decision to be made).

My WinSCP version is 5.7.1 on Windows 8. All updates have been installed on the Windows system.

Cheers,
-michael
WinSCP_Error.png (5.4 KB)

Description: Screenshot w/ error message.

WinSCP_Error.png

Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Thanks for your report.

Quote:
First issue I'm facing from time to time, is that WinSCP stops working and present the error message "Class TAnimate not found". After clicking away the error message the right panel of the command view is gone and WinSCP has to be restarted. Please see the attached PNG for a screenshort.

Are you able to reproduce this in a reasonable time?

Quote:
The second issue is that I have a few workspace that I'm using to connect to my machines in one go. However, I cannot manage to keep the workspace from being saved when exiting WinSCP. If i click OK in the "Workspace 'XXX' will be saved" dialog, then some machine might be gone from the workspace. Checking "Never ask me again" also seems not right, because that raises the impression that the dialog will be gone, but the workspace will be saved. Am I doing something wrong here or is there an issue (or feature request)?

I'm not sure I understand. Do you have Automatically save workspace on exit on or off?
http://winscp.net/eng/docs/ui_pref_window
What is an exact wording of the prompt you refer to?

Quote:
Third, it seems that when "Transfer each file individually" is checked in the preferences, then you cannot confirm transfers using "Yes to all", "No to all", etc. It would be great if WinSCP could remember which files had been dropped and then takes an effect of the decision for all of the dropped files (or if need be for all files in the queue that would be waiting for a decision to be made).

That's true. Will try to improve this.
mjklemm
[View user's profile]

Joined: 2015-04-15
Posts: 3
Location: Germany
prikryl wrote:
Thanks for your report.


No problem! Thanks for listening to my report! Very Happy

prikryl wrote:
Quote:
First issue I'm facing from time to time, is that WinSCP stops working and present the error message "Class TAnimate not found". After clicking away the error message the right panel of the command view is gone and WinSCP has to be restarted. Please see the attached PNG for a screenshort.

Are you able to reproduce this in a reasonable time?


I will try to reproduce it. So far, I do not see a pattern. If there's any debugging feature that you would like me to turn so that you can get more information about what was happening, please let me know. I can also use the VS debugger to look into the process, but I would need some guidance on where to look.

prikryl wrote:
Quote:
The second issue is that I have a few workspace that I'm using to connect to my machines in one go. However, I cannot manage to keep the workspace from being saved when exiting WinSCP. If i click OK in the "Workspace 'XXX' will be saved" dialog, then some machine might be gone from the workspace. Checking "Never ask me again" also seems not right, because that raises the impression that the dialog will be gone, but the workspace will be saved. Am I doing something wrong here or is there an issue (or feature request)?

I'm not sure I understand. Do you have Automatically save workspace on exit on or off?
http://winscp.net/eng/docs/ui_pref_window
What is an exact wording of the prompt you refer to?


I might have misunderstood that option then. I thought it would only apply to the default workspace. I will turn off this option, so that WinSCP does not save the workspace anymore and then manually save the workspaces from time to time. Works for me.


prikryl wrote:
Quote:
Third, it seems that when "Transfer each file individually" is checked in the preferences, then you cannot confirm transfers using "Yes to all", "No to all", etc. It would be great if WinSCP could remember which files had been dropped and then takes an effect of the decision for all of the dropped files (or if need be for all files in the queue that would be waiting for a decision to be made).

That's true. Will try to improve this.


Cool! Thanks!

Cheers,
-michael
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
mjklemm wrote:
I will try to reproduce it. So far, I do not see a pattern. If there's any debugging feature that you would like me to turn so that you can get more information about what was happening, please let me know. I can also use the VS debugger to look into the process, but I would need some guidance on where to look.

I have sent you an email with a debug version of WinSCP to address you have used to register on this forum.
_________________
Martin Prikryl
mjklemm
[View user's profile]

Joined: 2015-04-15
Posts: 3
Location: Germany
Hi,

prikryl wrote:
mjklemm wrote:
I will try to reproduce it. So far, I do not see a pattern. If there's any debugging feature that you would like me to turn so that you can get more information about what was happening, please let me know. I can also use the VS debugger to look into the process, but I would need some guidance on where to look.

I have sent you an email with a debug version of WinSCP to address you have used to register on this forum.


I have not received the email. I guess that the email firewall has filtered your email. Can you share a download link with me?

Cheers,
-michael
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
I have resent the email, please check again.
Karel Dytrych

Guest


Hello,
I'm getting "Class TAnimate not found" almost every week. It never hapeeaned in previous versions. I have Win 10 and WinSCP 5.7.6.

How to turn on debugging mode? I would like to give you more info...
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Thanks for your report.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
This issue has been added to the tracker:
https://winscp.net/tracker/show_bug.cgi?id=1415
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License