Topic "Escape spaces in console mode"

Author Message
supercleanse

Guest


I'm trying to synchronize a local folder to a remote folder but I'm having prolems escaping spaces in my paths... Is there any way to synchronize folders with spaces in their paths? Example:

winscp>synchronize c:\Documents and Settings\supercleanse\My Documents /home/supercleanse/My Documents
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Enclose the path in quotes, like:

winscp>synchronize "c:\Documents and Settings\supercleanse\My Documents" "/home/supercleanse/My Documents"
_________________
Martin Prikryl
andy

Guest


How can this be done from the command line?

winscp3.com /command "open ....." syncrhonize local "Docs and Sets" ./

Complains about the number of parameters.



supercleanse wrote:
I'm trying to synchronize a local folder to a remote folder but I'm having prolems escaping spaces in my paths... Is there any way to synchronize folders with spaces in their paths? Example:

winscp>synchronize c:\Documents and Settings\supercleanse\My Documents /home/supercleanse/My Documents
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
You cannot do this from command line (due to limitation of Windows parsing capabilities).
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License