Topic "TLS/SSL FTP explicit file transfer, control connection timeout"

Author Message
gozi
[View user's profile]

Joined: 2015-11-15
Posts: 1
Hi all,
My provider firewall's TCP session timeout is ~5 minutes. Local and the remote side behind NAT+firewall. I use TLS/SSL FTP explicit connection. Connection settings: Passive mode, Executing dummy protocol commands, seconds between keepalives: 30 seconds.

If the file transfer takes longer time than the session timeout, after uploading a file is completed, I get "Timeout detected. (control connection)" message (but only when the transfer takes longer than time of the session timeout per file).

I think, while uploading files, the control connection TCP session is disconnected, beceause keepalives not sent.

It is possible while uploading files send keepalives to prevent control connection TCP session disconnected? (Putty 0.66 connections disconnect here too, without set seconds between keepalives)

Thank you!
ftp_tls_ssl_expl_control_no_timeout.log (43.36 KB) Private file

Description: Transfer time per file shorter than session timeout.

ftp_tls_ssl_expl_control_timeout.log (89.34 KB) Private file

Description: Transfer time per file longer than session timeout.

Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
No, you cannot send keepalives on FTP control connection while the transfer is ongoing.
peter72

Guest


Same problem with my wireless provider, with almost same configuration, but for me the TCP disconnect time is only 2 minutes. The service provider does not want change the session timeout value.

Feature request: After the file transfer finished, if the control connection disconnect is occurs, try first auto reconnect without error window, and without wait until reconnection timeout expires and go to the next file, or close the file transfer process. The error window show up, if second reconnection fails too.

Thanks!
VictorVG

Guest


I read You bug-report http://bugs.farmanager.com/view.php?id=3249 in Far Manager Mantis. Please, go to NetBox panel, Your session, Connection, and set Time-aut > 300s and check box "Executing dummy protocol commands" for correct current FTP settings. Is local server settings problem.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License