Topic "searching and symlinks : stuck in a loop"

Author Message
smitty123
[View user's profile]

Joined: 2014-10-26
Posts: 36
Location: Canada
using the search function (find files) , it gets stuck in an endless loop adding the path to the search path in an infinite loop, like the picture shows, notice the path at bottom of the window.

it never finishes the search.

winscpp 5.82 beta (b6284)
searchlooppath.PNG (12.3 KB)

Description: (none)

searchlooppath.PNG

Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
smitty123
[View user's profile]

Joined: 2014-10-26
Posts: 36
Location: Canada
here are the logs

all i did was use find files for something in /sys and it got caught in a loop at

2016-05-16 16:45:38.513 Listing directory "/sys/bus/i2c/devices/i2c-0".
logs.zip (166.69 KB) Private file

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Thanks for the log.

I can see that in the i2c-0 folder, there's a device symlink to ../../mv64xxx_i2c.0. What is the mv64xxx_i2c.0? Is a symlink again? To i2c-0 or where?
smitty123
[View user's profile]

Joined: 2014-10-26
Posts: 36
Location: Canada
prikryl wrote:
Thanks for the log.

I can see that in the i2c-0 folder, there's a device symlink to ../../mv64xxx_i2c.0. What is the mv64xxx_i2c.0? Is a symlink again? To i2c-0 or where?


looking in /sys/devices/platform/mv64xxx_i2c.0/i2c-0 i see what's in image i2c-0.png

and a symlink named "device" no "s" and that just points to ../../mv64xxx_i2c.0

aka /sys/devices/platform/mv64xxx_i2c.0 in absolute path. a parent folder.
i2c-0.PNG (87.98 KB) [Download]

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
This bug was reopened to cover this issue:
https://winscp.net/tracker/show_bug.cgi?id=1093

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License