Topic ""set permissions" not working"

Author Message
10basetom
[View user's profile]

Joined: 2003-04-05
Posts: 1
i hope someone can help me with this...

when i transfer read-only files, the permissions on the remote server get set to -r--r--r-- (444) even though i enabled "set permissions" in winscp to chmod the files to -rw-r--r-- (644).

is this a bug, and if yes then is there a workaround?

thanks in advance,
10bt
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
This should work. Maybe there is something with your server that prevents permission change. Sorry, I have no idea.
_________________
Martin Prikryl
Guest




UPDATE: i found that everything works as expected after i disabled the 'preserve read-only' option.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
This option should be available only on download. You have the option visible on upload? Have you latest version of WinSCP?
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License