Topic ""Ungltiger Zugriff auf den Speicher""

Author Message
setti

Guest


Ich nutze Windows Server 2003 (Standard) fr x64.

Ich denke ma da gibts ein kleines Problem mit dem Speicherzugriff unter 64Bit <-> 32Bit.

Hoffe es kommt da ein BugFix fr raus.

Das Programm lsst sich so starten, merkt sich aber nicht, die Einstellungen fr Editoren usw.)

Dennoch KLASSE ARBEIT!
Advertisements
Guest




Genau das selbe Problem haben wir hier auch.
Guest




Hat denn jemand schon gehrt, dass an dem Problem gearbeitet wird? Ich wollte das Tool einsetzen und habe unter Win2003 64bit erstmal nur die genannten Fehlermeldungen.
pat

Guest


I get the message "Ungltiger Zugriff auf den Speicher" ("Invalid access to memory") under Win32 too - at every start. And the settings aren't stored (or restored). Independent of using INI or registry as storage for the configuration.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
pat wrote:
I get the message "Ungltiger Zugriff auf den Speicher" ("Invalid access to memory") under Win32 too - at every start. And the settings aren't stored (or restored). Independent of using INI or registry as storage for the configuration.

Does it happen if you remove german translation?
_________________
Martin Prikryl
jack-pot
[View user's profile]

Joined: 2006-05-19
Posts: 2
Quote:
Does it happen if you remove german translation?


Hi

I'm not pat, but I had the same error on every start and exit. Although my settings were not affected.

Without "WinSCP3.de" (renamed), the error is gone. Very Happy

If you need some testing done by me, let me know.

Thorsten
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
jack-pot wrote:
I'm not pat, but I had the same error on every start and exit. Although my settings were not affected.

Without "WinSCP3.de" (renamed), the error is gone. Very Happy

What version of WinSCP are you using? Do you have up to date German translation? Does the error go away, if you keep the German translation, only changing the language to English (in previous session)?
_________________
Martin Prikryl
jack-pot
[View user's profile]

Joined: 2006-05-19
Posts: 2
Skip to --- for the solution...

I'm using version 3.8.1 (Build 328), clean install from
winscp381setupintl.exe.

WinSCP3.de is dated 2006-05-07 20:29

If I have WinSCP3.de in the winscp program folder, I get the error message on launch (and a german user interface).
Clicking the "Languages" button (NOT translated into german), I get another error message (Ungltiger...) and no language selection dialog.
Clicking again on "Languages" gives a dropdown list with only "mehr Sprachen..." as list item (which opens http://winscp.net/eng/translations.php).

So I can't change languages from inside winscp.

With both the german and danish language files present I get the same behavior as with only the german one (error on start, exit and "Languages" button).

With only the danish language file, I get no error message on start and exit, but a "Invalid access to memory" error on the first click on the "Languages" button and a _english_ user interface.


Argh. And after writing this all I was about to write something about my OS (XP-Prof SP2) and gear (Athlon64).
And I was thinking about the DEP setting (enabled for all exept for those I select).

---

And the solution is: put WinSCP into the DEP-exeption-list and the errors are gone Very Happy

So for others searching for a "Ungltiger Zugriff auf den Speicher"-cure:

go to Microsofts "How to Configure Memory Protection in Windows XP SP2": http://www.microsoft.com/technet/security/prodtech/windowsxp/depcnfxp.mspx

scroll down to "Enabling the DEP Exception List", follow the text and add WinSCP3.exe to the exception list.

A happy rest of the week for all
Thorsten
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Thanks!
_________________
Martin Prikryl
pat

Guest


jack-pot wrote:

Without "WinSCP3.de" (renamed), the error is gone. Very Happy


same on my PC. I removed the german translation file and it works.

There is a secondary problem in the same issue. With the german translation file WinSCP was unable to store the preferences. Everytime I restart WiNSCP it starts with the same (ugly) settings. Now (without the german translation file) I can see more sensefull settings and automatic preference saving ant program termination works too.

My hint: Maybe you're using a translated specifier for some registry keys? This would explain, why I have "no" settings in the german version. And if translation is used just at loading the preferences, this would explain why the automatic saved settings are not found at next program start.

Maybe this helps. keep hackin'
mo

Guest


Thanks!! DEP really is the solution!
spuky

Guest


mo wrote:
Thanks!! DEP really is the solution!


he is fully right, I can work on my vista 64 system with german translation. And also save settings.. as soon as I enabled DEP in opt out mode Winscp would bring up this error.. and won't use the allready made settings..

as soon as i opted it out of DEP it is working normal...
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
This problem was resolved already and will be fixed in the next release.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License