Topic "Another timestamp issue"

Author Message
usch
[View user's profile]

Joined: 2006-03-21
Posts: 7
DST is in effect here in Germany since today. Now all timestamps displayed in the remote window are one hour ahead - see screenshot.

If I turn on the "Server adjusts DST" option, timestamps of files created with DST in effect are shown orrectly, while timestamps of files created during standard time are stil wrong.

This apparently affects only the timestamp display, not the actual timestamps of files as they are uploaded.

If I use SCP instead of SFTP and set the timezone offset to -1, timestamp display seems to be ok, but now the actual timestamp of file copies is one hour behind, so changing protocols does not help much.

Same behaviour with V3.8.0 and V3.7.6.

Due to the one hour offset I cannot use the "synchronize" function at all anymore - it would want to download every file on the server :( Help??
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
Changing the option now does not solve the problem. You should have it set correctly before uploading the files. You can use timestamp synchronisation function to resolve the problem.
_________________
Martin Prikryl
usch
[View user's profile]

Joined: 2006-03-21
Posts: 7
Sorry, but you did not get the point here. There is no "upload" involved in the first place. The timestamp of all files is displayed incorrectly, no matter if they have been uploaded with WinSCP, uploaded with any other client, or created directly on the server.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
Still, you can use timestamp synchronisation function to resolve the problem. But please use 3.7.6 as the functionality is broken in 3.8.
_________________
Martin Prikryl
usch
[View user's profile]

Joined: 2006-03-21
Posts: 7
You still don't get the point. This has nothing to do with synchronisation. Timestamps are off by one hour even if there is no local copy of the file at all.
Erik

Guest


usch wrote:
You still don't get the point. This has nothing to do with synchronisation. Timestamps are off by one hour even if there is no local copy of the file at all.


I have the same issue at all my servers. If I connect with CuteFtp the timestamps are correct, but if I try with WinSCP all files have timestamps that are 1 hour ahead the local time of the server and mine.

And I have not uploaded the files with WinSCP.

Strange issue. Confused
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
Can I have a test account on any of the servers?
_________________
Martin Prikryl
JJ

Guest


I have similar problem (and it's not about last version, it's there at least 3 years).
When I set "Server works in UTC", uploaded files show correct time in WinSCP, but wrong time in Putty (ls -l command):
WinSCP: faktury 2.4.2006 0:35:21
Putty: faktury Apr 1 23:35

When I set "Server adjust DST", WinSCP shows the same time as before, but when I upload a file, it's time is shifted 1 hour forward:

Before upload:
WinSCP: faktury 2.4.2006 0:35:21
Putty: faktury Apr 1 23:35

After uploading the file again with "Server adjust DST":
Putty: faktury Apr 2 00:35
WinSCP: faktury 2.4.2006 1:35:21

When I change remote file (in Putty or by a remote script) it shows correct time in putty and 1 hour more in WinSCP:
Putty: faktury Apr 2 13:12
WinSCP: faktury 2.4.2006 14:12:26

So it seems, that "Server adjust DST" is correct setting for me, because it sets time to correct value. But I must use "Server works in UTC" to see correct time in WinSCP and to use "Compare directories" command Sad
usch
[View user's profile]

Joined: 2006-03-21
Posts: 7
I have set up a test account on my server. E-mail me for the details, please.
acar
[View user's profile]

Joined: 2006-02-28
Posts: 10
Location: Belgrade, Serbia
I noticed this problem when installed new version(s).
It happens with V3.8.0 and V3.7.6, but it works correctly with V3.7.4 Exclamation Exclamation Exclamation

I can't set time on my remote server before DST, but because people didn't complain earlier, it seems it is in some connection with DST. Confused
kdiethri

Guest


I think I am having the same problem.

I have "Automaticly adjust clock for DST" on my local Windows 2000 system. The times on the files on my system are all incorrectly reported by 1 hour in WinSCP. The files show the correct time on the remote Unix system.

When I sync by time, of course it want's to sync everything, so I do. However when the files are moved to the remote Unix server, the times are correct again. This is because the modify time of the file is right, but Windows is interpreting it "incorrectly". Microsoft would say they are doing it right and the rest of the world is wrong. See:
http://www.codeproject.com/datetime/dstbugs.asp

How to fix this, I have no idea... Turning off the "Automatic" checkbox and setting time myself works until my PC syncs with a time server. Then I am messed up again.
Guest




Same problem here (Holland = GMT+1).
Timestamps of all my files are one hour ahead. FileZilla is displaying the correct times and so is Putty.
Guest




I'm sorry, I'm used to being signed in in forums so I don't put in a signature. The previous post is mine and here's my signature Wink

Regards, Peter van der Leek
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
acar wrote:
I noticed this problem when installed new version(s).
It happens with V3.8.0 and V3.7.6, but it works correctly with V3.7.4

Since 3.7.6 the Unix-style approach to Daylight saving time (client does adjustment) was made default.
_________________
Martin Prikryl
usch
[View user's profile]

Joined: 2006-03-21
Posts: 7
If it's a default, then I would expect an option to change this. The only DST related option I can find, however, is "Server works in UTC" / "Server adjusts DST" which doesn't seem to have any effect at all.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
usch wrote:
If it's a default, then I would expect an option to change this. The only DST related option I can find, however, is "Server works in UTC" / "Server adjusts DST" which doesn't seem to have any effect at all.

I believe that it must have some effect.
_________________
Martin Prikryl
Guest




Works for me! I've set the option to "Server adjusts DST" for all my sessions and the timestamps are now displayed correctly! Mr. Green

Regards, Peter van der Leek
usch
[View user's profile]

Joined: 2006-03-21
Posts: 7
Ok, I double checked the "Server adjusts DST" option and I confirm that it has some effect.

However, while with this option off the times shown are consistently one hour ahead, we now have to distinguish four different cases.

1) Files created on the server during standard time, then downloaded with WinSCP: Time shown by WinSCP is one hour ahead, and so is the local file's timestamp.

2) Files created on the server during DST, then downloaded with WinSCP: All timestamps match.

3) Files created locally during standard time, then uploaded with WinSCP: Timestamp on the server is one hour behind. This compensates for the "one hour ahead" display so that file time appears to be correct when viewed with WinSCP, but in fact it is not.

4) Files created locally during DST, then uploaded with WinSCP: All Timestamps match.

So we have a problem that only strikes when

  • DST is in effect, and
  • Server handles DST, and
  • the "Server handles DST" option in WinSCP is set, and
  • we deal with older files that have been created when DST was not in effect

Hm.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
After regaining my knowledge about timestamp issues from the times I were implementing the timestamp conversion functionality, I have tried to explain current WinSCP behaviour in documentation.

So far I believe that WinSCP is behaving correctly (consistently), at least when run on NT-class version of Windows, while being connected to non-Windows server (option "Server works in UTC time" is on).

I'm looking forward for your feedback.

BTW, I have tried several other SFTP clients (PSFTP, Filezilla, Tunnelier, SecureFX). I believe that out of these, WinSCP is performing the best Smile
peter wilson

Guest


I'm having real problems with this right now.

Local drive shows correct time.

Remote server is OpenBSD 3.6

With 'Server works in UTC...' and transfer a file to the remote system, the timestamp in both windows agrees. If however I then look on the server (ls -l) the recorded timestamp is 1 hour earlier.

Files already on the server behave as follows:
ls -l : time stamp 02:14, winscp report 03:14.

If I switch to 'Server adjusts for DST' then times for all files including those transfered with WinSCP are forward by one hour.

The above is true using SFTP or SCP.

The server has openSSL 0.9.7d installed of that helps at all.

Output from 'ls -l' formatted as follows:
---------- 1 user group size month date hrs:mins filename

I'm using WinSCP 3.8.2, but this problem has persisted over a lot of releases (it's just starting to annoy me more and more!)

Help very much appreciated.



If I change this to
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
This is explained in the documentation, as linked in my previous topic.
_________________
Martin Prikryl
Banex

Guest


WinSCP ver.4.3.5

Local: Windows XP CEST timezone
Remote: CentOs CEST timezone
Remote FTP ProFTP running on CEST timezone

When connecting to remote via WinSCP, i had to set-up 1 min remote difference, after which all files are on same timestamp.

Timestamps also verified on the remote via shell.

When you select "Keep Remote directory up to date", wiscp runs full sync and does not find any differences (which is right).

WinSCP now waits for chages.

Any change to local file, change is detected and sync started.
Immediately after that, remote dir is off by 2 hours (-2) and WinSCP is now syncing all files from local to remote.

To get back to proper timesync, I have to disconnect and connect again.

CU! BAnex
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
Banex wrote:
When connecting to remote via WinSCP, i had to set-up 1 min remote difference, after which all files are on same timestamp.

Timestamps also verified on the remote via shell.

When you select "Keep Remote directory up to date", wiscp runs full sync and does not find any differences (which is right).

WinSCP now waits for chages.

Any change to local file, change is detected and sync started.
Immediately after that, remote dir is off by 2 hours (-2) and WinSCP is now syncing all files from local to remote.

To get back to proper timesync, I have to disconnect and connect again.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License