Topic "Overwriting files with 660 permissions - new issue"

Author Message
teixa
[View user's profile]

Joined: 2007-10-26
Posts: 3
Location: Portugal
Hi,

I was going to file this as a new bug, but then I found this in the FAQ:

"I need to overwrite a remote file that isn't owned by me, but I'm
member of its group. The file has write permission for group. After
transfer I get a message like 'Upload of file <filename> was successful,
but error occurred while setting the permissions and/or timestamp'"

"While copying files such as this, you need to turn off Set permissions
and Preserve timestamp options or turn on Ignore permission errors"

This almost describes my problem exactly, the thing is the error message
I get is different:

"Copying file <file> failed."

The file gets transfered anyway. My problem is that the second solution
in the FAQ - "turn on Ignore permission errors" - doesn't solve the
problem. This may have something to do with the fact that the error
message isn't really a permissions message, but it should be.

I'm using WinSCP 4.0.5, protocol SCP, Norton commander style.

Thank you.

Bruno Teixeira
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24552
Location: Prague, Czechia
The error message is more general as with SCP, WinSCP is not able to distinguish this particular problem. Also with SCP the "Ignore permissions errors" is not working (for the same reason). The option should be disabled with SCP.

Note that you need to turn off also "Preserve timestamp" option to overcome this.
_________________
Martin Prikryl
teixa
[View user's profile]

Joined: 2007-10-26
Posts: 3
Location: Portugal
Hi and thanks for your reply.

prikryl wrote:
The error message is more general as with SCP, WinSCP is not able to distinguish this particular problem. Also with SCP the "Ignore permissions errors" is not working (for the same reason). The option should be disabled with SCP.


Done.

prikryl wrote:
Note that you need to turn off also "Preserve timestamp" option to overcome this.


The thing is I need to turn of "Preserve timestamp" and "set permissions". But this way, the user has to constantly change the options when he wants to overwrite, because when creating new files, the permission must be 660. Since these are users that aren't very familiar with such things, this can't be.

Are my only solutions getting them to disregard the Error message or trying to give their user permissions to chmod? I could I to this? I have access to the server config...

Take care
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24552
Location: Prague, Czechia
teixa wrote:
Are my only solutions getting them to disregard the Error message or trying to give their user permissions to chmod? I could I to this? I have access to the server config...

What about using SFTP? I do not think you can grant the users permissions to chmod.
_________________
Martin Prikryl
teixa
[View user's profile]

Joined: 2007-10-26
Posts: 3
Location: Portugal
prikryl wrote:
What about using SFTP? I do not think you can grant the users permissions to chmod.


Yes, using SFTP solved my problem. "Ignore permission erros" works now.

Thank you.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License