Topic "Cant FTP: Error listing directory"

Author Message
anjanesh
[View user's profile]

Joined: 10 Nov 2007
Posts: 4
Location: Mumbai, India
Hi

Im trying to connect to a remote server via FTP (port 21) but I get this this error msg :
Code:

Timeout detected.
Could not retrieve directory listing
PORT command successful
Error listing directory '/'.

I tried connecting to various linux hosts but all returned the same msg.

But SFTP works though.

WinSCP 4.0.4

Is there some setting I got to use to connect via FTP ?

Thanks
Advertisements
G Jones

Guest


I am getting the same error - I was hoping 4.05 was going to work on my w98se system - as I had failed to get it working due to a netapi32 problem previously.
Quote:
Timeout detected.
Could not retrieve directory listing
PORT command successful
Error listing directory '/'.
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
anjanesh wrote:
Im trying to connect to a remote server via FTP (port 21) but I get this this error msg :
Code:

Timeout detected.
Could not retrieve directory listing
PORT command successful
Error listing directory '/'.

I tried connecting to various linux hosts but all returned the same msg.

But SFTP works though.

WinSCP 4.0.4

Is there some setting I got to use to connect via FTP ?

Have you tried passive mode?
_________________
Martin Prikryl
anjanesh
[View user's profile]

Joined: 10 Nov 2007
Posts: 4
Location: Mumbai, India
Quote:
Have you tried passive mode?

Thank You ! It now works.

Can it not auto-detect which mode it should try ? Or try active first, if fail, try passive ?
_________________
Anjanesh
http://anjanesh.blogspot.com
snowwolf
[View user's profile]

Joined: 05 Dec 2007
Posts: 1
How can I set winscp to use passive mode ftp?
anjanesh
[View user's profile]

Joined: 10 Nov 2007
Posts: 4
Location: Mumbai, India
After selecting FTP (from the drop down),
goto Connection section (select from left-hand pane of menus)
and check Passive. By default its unchecked.

_________________
Anjanesh
http://anjanesh.blogspot.com
Tias

Guest


I have the same problem but i can`t check passive mode. it`s faded (if you know what I mean)
striped67

Guest


Tias wrote:
I have the same problem but i can`t check passive mode. it`s faded (if you know what I mean)


Select the stored session, click Edit. Click on Connection on the left-hand side and the Passive mode checkbox should be enabled. Don't forget to save the session after you've changed it.

Took me a while to work it out, but now it's working like a dream.
jigujigu
[View user's profile]

Joined: 16 Jan 2008
Posts: 2
how i can set passive mode in command line.

i am not using Open Session command
this is my command line

winscp.exe /script=send.scp

this is my Send.Scp file
option batch on
option confirm off
Open ftp://MyId03:Pass11@MyServer:21
PUT C001.DAT C001.DAT

I am using WinSCP 4.0.6

thank's
Jigu Haslim
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
jigujigu wrote:
how i can set passive mode in command line.

Please read FAQ.
_________________
Martin Prikryl
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
jigujigu wrote:
how i can set passive mode in command line.

This issue is being tracked already.
_________________
Martin Prikryl
Gus

Guest


Bless you people.

I've spent 3 days banging my head on my desk, emailing my host, talking to our IT people, asking God and anyone else that would listen, how to solve this problem.

PASSIVE MODE was all it took.... thank you so much people on this forum, you have answered my prayers. Very Happy
anjanesh
[View user's profile]

Joined: 10 Nov 2007
Posts: 4
Location: Mumbai, India
prikryl should make it passive by default or auto-try in passive mode when active mode fails.
_________________
Anjanesh
http://anjanesh.blogspot.com
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
anjanesh wrote:
prikryl should make it passive by default or auto-try in passive mode when active mode fails.

This request has been added to tracker.
_________________
Martin Prikryl
deviljoo

Guest


I had the same problem to, but i turned off the windows firewall and that fixed the error...
Guest




striped67 wrote:
Tias wrote:
I have the same problem but i can`t check passive mode. it`s faded (if you know what I mean)


Select the stored session, click Edit. Click on Connection on the left-hand side and the Passive mode checkbox should be enabled. Don't forget to save the session after you've changed it.

Took me a while to work it out, but now it's working like a dream.


that doesn't work for me
HELP Crying or Very sad
alpesh

Guest


Hello,
After Passive mode it worked for me
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
See documentation for hints and solutions regarding "Error listing directory" error.
_________________
Martin Prikryl
cypherx

Guest


Passive mode didn't work for me.

I'm using WinSCP 4.1.5 (Build 410)
I'm copying all my saved sites out of an old netmanage.95 ftp client into WinSCP. I have a site that is FTP that will not list any files in the default directory. I can't get WinSCP to display the default directory.

I tried leaving Remote Directory blank, and I also tried putting in the name without a slash, and also with a slash from the output of a Wireshark analyzer after logging in with the working FTP Client.

I'm getting
Could not retrieve directory listing
CWD cmd failed : EDC5129l No such file or directory. (errno2=0x0594003D)
I click OK and I'm connected but the directory doesn't show any files. In the upper right drop down I see the directory name 'FX04394.' which is exactly the home directory when windows\system32\ftp (command line) places you upon login.

Thanks for your help.
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
cypherx wrote:
I'm getting
Could not retrieve directory listing
CWD cmd failed : EDC5129l No such file or directory. (errno2=0x0594003D)
I click OK and I'm connected but the directory doesn't show any files. In the upper right drop down I see the directory name 'FX04394.' which is exactly the home directory when windows\system32\ftp (command line) places you upon login.

What is your FTP server and operating system?
_________________
Martin Prikryl
cypherx

Guest


prikryl wrote:
cypherx wrote:
I'm getting
Could not retrieve directory listing
CWD cmd failed : EDC5129l No such file or directory. (errno2=0x0594003D)
I click OK and I'm connected but the directory doesn't show any files. In the upper right drop down I see the directory name 'FX04394.' which is exactly the home directory when windows\system32\ftp (command line) places you upon login.

What is your FTP server and operating system?


I'm not entirely sure, it's not our FTP server, it's a vendor we use. I have to use a different FTP client for that one site and it works fine. Too bad because I wanted to consolidate and use WinSCP for everything since it also does SFTP/SSH2 in addition to regular FTP.

Here's an output of the STAT command:
211-Server FTP talking to host xxx.xxx.xxx.xxx, port 36214
211-User: xxxxxx Working directory: xxxxxx.
211-The control connection has transferred 1715 bytes
211-There is no current data connection.
211-The next data connection will be actively opened
211-to host xxx.xxx.xxx.xxx, port 36214,
211-using Mode Stream, Structure File, type ASCII, byte-size 8
211-Automatic recall of migrated data sets.
211-Automatic mount of direct access volumes.
211-Auto tape mount is allowed.
211-Inactivity timer is set to 300
211-Timer FTPKEEPALIVE is set to 600
211-VCOUNT is 59
211-ASA control characters in ASA files opened for text processing
211-will be transferred as ASA control characters.
211-Trailing blanks are removed from a fixed format
211-data set when it is retrieved.
211-Data set mode. (Do not treat each qualifier as a directory.)
211-ISPFSTATS is set to FALSE
211-Primary allocation 30 tracks. Secondary allocation 30 tracks.
211-FileType SEQ (Sequential - default).
211-Number of access method buffers is 5
211-RDWs from variable format data sets are discarded.
211-Records on input tape are unspecified format
211-SITE DB2 subsystem name is DB2
211-Data not wrapped into next record.
211-Tape write is not allowed to use BSAM I/O
211-Truncated records will not be treated as an error
211-JESLRECL is 80
211-JESRECFM is Fixed
211-JESINTERFACELEVEL is 1
211-Server site variable JESTRAILINGBLANKS is set to TRUE
211-Migrate Volid is ARCIVE
211-Confidence level in data transfers is neither checked nor reported
211-ENcoding is set to SBCS
211-Outbound SBCS ASCII data uses CRLF line terminator
211-Outbound MBCS ASCII data uses CRLF line terminator
211-Server site variable MBREQUIRELASTEOL is set to TRUE
211-Server site variable UNICODEFILESYSTEMBOM is set to ASIS
211-DBSUB is set to FALSE
211-SBSUB is set to FALSE
211-SBSUBCHAR is set to SPACE
211-SMS is active.
211-Data sets will be allocated using unit DISK
211-New data sets will be catalogued if a store operation ends abnormally
211-Single quotes will override the current working directory.
211-UMASK value is 027
211-Process id is 50331936
211-Checkpoint interval is 0
211-Authentication type: None
211-TLS security is supported at the DRAFT level
211-'TCPIP.MODEL.DCB' will be used as the DCBDSN model data set
211-Port of Entry resource class for IPv4 clients is: TERMINAL
211-Record format FB, Lrecl: 80, Blocksize: 6160
211-Server site variable LISTSUBDIR is set to TRUE
211 *** end of status ***


211- Extensions supported
AUTH TLS
PBSZ
PROT
211 End
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
cypherx wrote:
I'm not entirely sure, it's not our FTP server, it's a vendor we use. I have to use a different FTP client for that one site and it works fine. Too bad because I wanted to consolidate and use WinSCP for everything since it also does SFTP/SSH2 in addition to regular FTP.
...

Hmm, I'm not familiar with this one. Sorry.
_________________
Martin Prikryl
DavidH

Guest


How do I get the PASV mode to be available? Even when creating a new connection I don't get the option of selecting a PASV.
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
DavidH wrote:
How do I get the PASV mode to be available? Even when creating a new connection I don't get the option of selecting a PASV.

Please read documentation. If that does not help, come back.
_________________
Martin Prikryl
maya

Guest


i have the same problem with above.

Quote:
Timeout detected.
Could not retrieve directory listing
PORT command successful
Error listing directory '/'.


Then, i checked passive mode.

But it still have problem.
Quote:
Timeout detected.
Could not retrieve directory listing
Entering Passive Mode ().
Error listing directory '/'.


Can anybody help me?
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl
DragonRider317
[View user's profile]

Joined: 30 Sep 2010
Posts: 3
maya wrote:
i have the same problem with above.

Quote:
Timeout detected.
Could not retrieve directory listing
PORT command successful
Error listing directory '/'.


Then, i checked passive mode.

But it still have problem.
Quote:
Timeout detected.
Could not retrieve directory listing
Entering Passive Mode ().
Error listing directory '/'.


Can anybody help me?


I am having similar problem. I have checked passive mode.

My log is as follows:

. 2010-09-30 10:10:49.910 --------------------------------------------------------------------------
. 2010-09-30 10:10:49.910 Session name: jdude@denali.zzzzz.org
. 2010-09-30 10:10:49.910 Host name: denali.zzzzz.org (Port: 990)
. 2010-09-30 10:10:49.910 User name: jdude (Password: Yes, Key file: No)
. 2010-09-30 10:10:49.910 Tunnel: No
. 2010-09-30 10:10:49.910 Transfer Protocol: FTP
. 2010-09-30 10:10:49.910 Ping type: C, Ping interval: 30 sec; Timeout: 15 sec
. 2010-09-30 10:10:49.910 Proxy: none
. 2010-09-30 10:10:49.910 FTP: FTPS: Implicit SSL/TLS; Passive: Yes [Force IP: No]
. 2010-09-30 10:10:49.911 Local directory: C:\Users\j.dude\Documents, Remote directory: /net/XXXX, Update: No, Cache: Yes
. 2010-09-30 10:10:49.911 Cache directory changes: Yes, Permanent: Yes
. 2010-09-30 10:10:49.911 DST mode: 1
. 2010-09-30 10:10:49.911 --------------------------------------------------------------------------
. 2010-09-30 10:10:50.196 Connecting to denali.zzzzz.org:990 ...
. 2010-09-30 10:10:50.196 m_pSslLayer changed state from 0 to 1
. 2010-09-30 10:10:50.196 m_pSslLayer changed state from 1 to 2
. 2010-09-30 10:10:50.196 m_pSslLayer changed state from 2 to 4
. 2010-09-30 10:10:50.202 Connected with denali.zzzzz.org:990, negotiating SSL connection...
. 2010-09-30 10:10:50.373 SSL_connect: SSLv3 read server hello A
. 2010-09-30 10:10:50.373 SSL_connect: SSLv3 read server certificate A
. 2010-09-30 10:10:50.373 SSL_connect: SSLv3 read server key exchange A
. 2010-09-30 10:10:50.373 SSL_connect: SSLv3 read server done A
. 2010-09-30 10:10:50.373 SSL_connect: SSLv3 write client key exchange A
. 2010-09-30 10:10:50.373 SSL_connect: SSLv3 write change cipher spec A
. 2010-09-30 10:10:50.374 SSL_connect: SSLv3 write finished A
. 2010-09-30 10:10:50.374 SSL_connect: SSLv3 flush data
. 2010-09-30 10:10:50.607 SSL_connect: SSLv3 read finished A
. 2010-09-30 10:10:50.608 Using TLSv1, cipher TLSv1/SSLv3: EDH-RSA-DES-CBC3-SHA, 1024 bit RSA
. 2010-09-30 10:10:50.609 SSL connection established. Waiting for welcome message...
< 2010-09-30 10:10:50.609 220 Content Services FTPS Server ready. Access to this system is limited to authorized users for company business purposes only. Unauthorized access to or use of this system is prohibited and may subject you to civil and criminal prosecution. Use of this system may be monitored for the purpose of maintaining system security, and system information may be accessed or disclosed under limited circumstances.
> 2010-09-30 10:10:50.609 USER jdude
< 2010-09-30 10:10:50.613 331 Password required for jdude.
> 2010-09-30 10:10:50.614 PASS ******
< 2010-09-30 10:10:50.712 230 Login successful.
> 2010-09-30 10:10:50.712 SYST
< 2010-09-30 10:10:50.718 215 System type UNIX
> 2010-09-30 10:10:50.718 FEAT
< 2010-09-30 10:10:50.723 500 Command not supported: FEAT
> 2010-09-30 10:10:50.723 PBSZ 0
< 2010-09-30 10:10:50.729 200 Command successful.
> 2010-09-30 10:10:50.729 PROT P
< 2010-09-30 10:10:50.734 200 Command successful.
. 2010-09-30 10:10:50.736 Connected
. 2010-09-30 10:10:50.736 Got reply 1 to the command 1
. 2010-09-30 10:10:50.736 --------------------------------------------------------------------------
. 2010-09-30 10:10:50.736 Using FTP protocol.
. 2010-09-30 10:10:50.736 Doing startup conversation with host.
> 2010-09-30 10:10:50.738 PWD
< 2010-09-30 10:10:50.744 257 "/"
. 2010-09-30 10:10:50.744 Got reply 1 to the command 16
. 2010-09-30 10:10:50.746 Changing directory to "/net/XXXX".
> 2010-09-30 10:10:50.746 CWD /net/XXXX
< 2010-09-30 10:10:50.758 250 Command successful.
. 2010-09-30 10:10:50.758 Got reply 1 to the command 16
. 2010-09-30 10:10:50.758 Getting current directory name.
> 2010-09-30 10:10:50.758 PWD
< 2010-09-30 10:10:50.763 257 "/net/XXXX"
. 2010-09-30 10:10:50.764 Got reply 1 to the command 16
. 2010-09-30 10:10:50.766 Retrieving directory listing...
> 2010-09-30 10:10:50.766 TYPE A
< 2010-09-30 10:10:50.769 200 TYPE set to A.
> 2010-09-30 10:10:50.770 PASV
< 2010-09-30 10:10:50.775 227 Entering Passive Mode (10,248,50,104,230,166)
> 2010-09-30 10:10:50.775 LIST
< 2010-09-30 10:10:50.781 150 ASCII data connection for directory listing.
. 2010-09-30 10:11:05.113 Timeout detected.
. 2010-09-30 10:11:05.113 Could not retrieve directory listing
. 2010-09-30 10:11:05.113 Got reply 1004 to the command 2
* 2010-09-30 10:11:05.118 (ESshFatal) Lost connection.
* 2010-09-30 10:11:05.118 Timeout detected.
* 2010-09-30 10:11:05.118 Could not retrieve directory listing
* 2010-09-30 10:11:05.118 ASCII data connection for directory listing.
* 2010-09-30 10:11:05.118 Error listing directory '/net/XXXX'.

I am using Windows 7.

Let me know if you have any suggestions. Thank you.
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
DragonRider317 wrote:
I am having similar problem. I have checked passive mode.

Are you able to connect with any other FTP client?
_________________
Martin Prikryl
DragonRider317
[View user's profile]

Joined: 30 Sep 2010
Posts: 3
prikryl wrote:
DragonRider317 wrote:
I am having similar problem. I have checked passive mode.

Are you able to connect with any other FTP client?


I was able to connect to the FTP site with FileZilla in passive mode.
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
DragonRider317 wrote:
prikryl wrote:
DragonRider317 wrote:
I am having similar problem. I have checked passive mode.

Are you able to connect with any other FTP client?


I was able to connect to the FTP site with FileZilla in passive mode.

Can you post a filezilla log? Have you checked your firewall configuration/log, if it blocks WinSCP?
_________________
Martin Prikryl
DragonRider317
[View user's profile]

Joined: 30 Sep 2010
Posts: 3
prikryl wrote:
DragonRider317 wrote:
prikryl wrote:
DragonRider317 wrote:
I am having similar problem. I have checked passive mode.

Are you able to connect with any other FTP client?


I was able to connect to the FTP site with FileZilla in passive mode.

Can you post a filezilla log? Have you checked your firewall configuration/log, if it blocks WinSCP?


I was able to fix my issue by checking the Force IP address for passive mode connections option in the FTP options screen.
Guest




anjanesh wrote:
After selecting FTP (from the drop down),
goto Connection section (select from left-hand pane of menus)
and check Passive. By default its unchecked.


Thanks for Your help!
Very useful advice. Smile
Frankly saying, I didn't believe it works until I tried it on my own. Razz
Nettie

Guest


Those who say they cannot activate passive mode need to EDIT their already saved session. Or delete and create a new one if that is easier.

As stated in post above I was unable to access passive mode (grayed out) then after reading a previous post it explained to edit. Before this I was turning off my firewall and that worked. But choose passive mode instead.

Also these post really help so thank you.
Johnie

Guest


I had the same issue but changing the Tnternet Protocol version from Auto to IPv4 fixed it for me.
pe
[View user's profile]

Joined: 09 Nov 2011
Posts: 1
Hi,

I have a similiar problem: initial directory listing after having connected over FTPS fails.
WinSCP runs in a Win7 VM on a Linux host. I'm behind a firewall. Therefore the host system tunnels traffic over SSH offering a local SOCKS5 proxy. WinSCP in the VM uses this proxy. FTP without SSL encryption works fine...

FTP(S) Server <--> External Proxy <-SSH-> Host system/SOCKS5 proxy:5555 <--> VM

- Firewall of the VM is deactivated
- Passive mode is activated
- I tried "Force IP address for passive mode connections" which gives me also an error. But with this configuration, the file explorer opens displaying an empty directory "/ <root>" on server side.

LOG (Without "Force IP address (...)")
Quote:
. 2011-11-09 09:20:18.878 --------------------------------------------------------------------------
. 2011-11-09 09:20:18.878 WinSCP Version 4.3.2 (Build 1201) (OS 6.1.7601 Service Pack 1)
. 2011-11-09 09:20:18.878 Login time: Mittwoch, 9. November 2011 09:20:18
. 2011-11-09 09:20:18.878 --------------------------------------------------------------------------
. 2011-11-09 09:20:18.879 Session name: ***
. 2011-11-09 09:20:18.879 Host name: ftp.*** (Port: 21)
. 2011-11-09 09:20:18.879 User name: *** (Password: Yes, Key file: No)
. 2011-11-09 09:20:18.879 Tunnel: No
. 2011-11-09 09:20:18.879 Transfer Protocol: FTP
. 2011-11-09 09:20:18.879 Ping type: C, Ping interval: 30 sec; Timeout: 15 sec
. 2011-11-09 09:20:18.879 Proxy: SOCKS5
. 2011-11-09 09:20:18.879 HostName: 10.0.2.2 (Port: 5555); Username: ***; Passwd: Yes
. 2011-11-09 09:20:18.879 FTP: FTPS: Explicit SSL; Passive: Yes [Force IP: No]
. 2011-11-09 09:20:18.879 Local directory: default, Remote directory: home, Update: No, Cache: Yes
. 2011-11-09 09:20:18.879 Cache directory changes: Yes, Permanent: Yes
. 2011-11-09 09:20:18.879 DST mode: 1
. 2011-11-09 09:20:18.879 --------------------------------------------------------------------------
. 2011-11-09 09:20:18.956 Connecting to ftp.*** ...
. 2011-11-09 09:20:18.956 m_pProxyLayer changed state from 0 to 1
. 2011-11-09 09:20:18.956 m_pSslLayer changed state from 0 to 1
. 2011-11-09 09:20:18.956 m_pProxyLayer changed state from 1 to 2
. 2011-11-09 09:20:18.956 m_pSslLayer changed state from 1 to 2
. 2011-11-09 09:20:18.956 m_pProxyLayer changed state from 2 to 4
. 2011-11-09 09:20:18.973 m_pSslLayer changed state from 2 to 4
. 2011-11-09 09:20:18.975 Connected with ftp.***, negotiating SSL connection...
< 2011-11-09 09:20:19.031 220 ProFTPD 1.3.3e Server (ProFTPD) [***]
> 2011-11-09 09:20:19.032 AUTH SSL
< 2011-11-09 09:20:19.071 234 AUTH SSL successful
. 2011-11-09 09:20:19.114 SSL_connect: SSLv3 read server hello A
. 2011-11-09 09:20:19.114 SSL_connect: SSLv3 read server certificate A
. 2011-11-09 09:20:19.260 SSL_connect: SSLv3 read server key exchange A
. 2011-11-09 09:20:19.261 SSL_connect: SSLv3 read server certificate request A
. 2011-11-09 09:20:19.261 SSL_connect: SSLv3 read server done A
. 2011-11-09 09:20:19.261 SSL_connect: SSLv3 write client certificate A
. 2011-11-09 09:20:19.261 SSL_connect: SSLv3 write client key exchange A
. 2011-11-09 09:20:19.261 SSL_connect: SSLv3 write change cipher spec A
. 2011-11-09 09:20:19.261 SSL_connect: SSLv3 write finished A
. 2011-11-09 09:20:19.261 SSL_connect: SSLv3 flush data
. 2011-11-09 09:20:19.293 SSL_connect: SSLv3 read finished A
. 2011-11-09 09:20:19.299 Using TLSv1, cipher TLSv1/SSLv3: DHE-RSA-AES256-SHA, 1024 bit RSA
. 2011-11-09 09:20:19.307 SSL connection established. Waiting for welcome message...
> 2011-11-09 09:20:19.307 USER ***
< 2011-11-09 09:20:19.333 331 Password required for ***
> 2011-11-09 09:20:19.333 PASS *************
< 2011-11-09 09:20:19.393 230 User *** logged in
> 2011-11-09 09:20:19.393 SYST
< 2011-11-09 09:20:19.424 215 UNIX Type: L8
> 2011-11-09 09:20:19.427 FEAT
< 2011-11-09 09:20:19.450 211-Features:
< 2011-11-09 09:20:19.450 MDTM
< 2011-11-09 09:20:19.450 MFMT
< 2011-11-09 09:20:19.450 TVFS
< 2011-11-09 09:20:19.450 UTF8
< 2011-11-09 09:20:19.450 AUTH TLS
< 2011-11-09 09:20:19.450 MFF modify;UNIX.group;UNIX.mode;
< 2011-11-09 09:20:19.450 MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
< 2011-11-09 09:20:19.450 LANG en-US*
< 2011-11-09 09:20:19.450 PBSZ
< 2011-11-09 09:20:19.450 PROT
< 2011-11-09 09:20:19.450 REST STREAM
< 2011-11-09 09:20:19.450 SIZE
< 2011-11-09 09:20:19.454 211 End
> 2011-11-09 09:20:19.454 OPTS UTF8 ON
< 2011-11-09 09:20:19.475 200 UTF8 set to on
> 2011-11-09 09:20:19.475 PBSZ 0
< 2011-11-09 09:20:19.507 200 PBSZ 0 successful
> 2011-11-09 09:20:19.507 PROT P
< 2011-11-09 09:20:19.520 200 Protection set to Private
. 2011-11-09 09:20:19.524 Connected
. 2011-11-09 09:20:19.524 Got reply 1 to the command 1
. 2011-11-09 09:20:19.524 --------------------------------------------------------------------------
. 2011-11-09 09:20:19.524 Using FTP protocol.
. 2011-11-09 09:20:19.527 Doing startup conversation with host.
> 2011-11-09 09:20:19.543 PWD
< 2011-11-09 09:20:19.565 257 "/" is the current directory
. 2011-11-09 09:20:19.565 Got reply 1 to the command 16
. 2011-11-09 09:20:19.581 Getting current directory name.
. 2011-11-09 09:20:19.589 Retrieving directory listing...
> 2011-11-09 09:20:19.589 TYPE A
< 2011-11-09 09:20:19.615 200 Type set to A
> 2011-11-09 09:20:19.615 PASV
. 2011-11-09 09:20:19.615 m_pProxyLayer changed state from 0 to 1
< 2011-11-09 09:20:19.639 227 Entering Passive Mode (***).
> 2011-11-09 09:20:19.639 LIST -a
. 2011-11-09 09:20:19.639 m_pProxyLayer changed state from 1 to 2
. 2011-11-09 09:20:19.639 m_pProxyLayer changed state from 2 to 4
. 2011-11-09 09:20:34.213 Timeout detected.
. 2011-11-09 09:20:34.214 Could not retrieve directory listing
. 2011-11-09 09:20:34.214 Got reply 1004 to the command 2
* 2011-11-09 09:20:34.223 (ESshFatal) Lost connection.
* 2011-11-09 09:20:34.223 Timeout detected.
* 2011-11-09 09:20:34.223 Could not retrieve directory listing
* 2011-11-09 09:20:34.223 Entering Passive Mode (***).
* 2011-11-09 09:20:34.223 Error listing directory '/'.


LOG(With "Force IP address (...)")
Quote:
. 2011-11-09 09:23:41.869 --------------------------------------------------------------------------
. 2011-11-09 09:23:41.873 WinSCP Version 4.3.2 (Build 1201) (OS 6.1.7601 Service Pack 1)
. 2011-11-09 09:23:41.873 Login time: Mittwoch, 9. November 2011 09:23:41
. 2011-11-09 09:23:41.873 --------------------------------------------------------------------------
. 2011-11-09 09:23:41.873 Session name: ***
. 2011-11-09 09:23:41.873 Host name: ftp.*** (Port: 21)
. 2011-11-09 09:23:41.873 User name: *** (Password: Yes, Key file: No)
. 2011-11-09 09:23:41.873 Tunnel: No
. 2011-11-09 09:23:41.873 Transfer Protocol: FTP
. 2011-11-09 09:23:41.873 Ping type: C, Ping interval: 30 sec; Timeout: 15 sec
. 2011-11-09 09:23:41.873 Proxy: SOCKS5
. 2011-11-09 09:23:41.874 HostName: 10.0.2.2 (Port: 5555); Username: ***; Passwd: Yes
. 2011-11-09 09:23:41.874 FTP: FTPS: Explicit SSL; Passive: Yes [Force IP: Yes]
. 2011-11-09 09:23:41.874 Local directory: default, Remote directory: home, Update: No, Cache: Yes
. 2011-11-09 09:23:41.874 Cache directory changes: Yes, Permanent: Yes
. 2011-11-09 09:23:41.874 DST mode: 1
. 2011-11-09 09:23:41.874 --------------------------------------------------------------------------
. 2011-11-09 09:23:41.907 Connecting to ftp.*** ...
. 2011-11-09 09:23:41.919 m_pProxyLayer changed state from 0 to 1
. 2011-11-09 09:23:41.919 m_pSslLayer changed state from 0 to 1
. 2011-11-09 09:23:41.919 m_pProxyLayer changed state from 1 to 2
. 2011-11-09 09:23:41.920 m_pSslLayer changed state from 1 to 2
. 2011-11-09 09:23:41.921 m_pProxyLayer changed state from 2 to 4
. 2011-11-09 09:23:41.945 m_pSslLayer changed state from 2 to 4
. 2011-11-09 09:23:41.961 Connected with ftp.***, negotiating SSL connection...
< 2011-11-09 09:23:42.028 220 ProFTPD 1.3.3e Server (ProFTPD) [***]
> 2011-11-09 09:23:42.028 AUTH SSL
< 2011-11-09 09:23:42.081 234 AUTH SSL successful
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 read server hello A
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 read server certificate A
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 read server key exchange A
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 read server certificate request A
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 read server done A
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 write client certificate A
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 write client key exchange A
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 write change cipher spec A
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 write finished A
. 2011-11-09 09:23:42.234 SSL_connect: SSLv3 flush data
. 2011-11-09 09:23:42.271 SSL_connect: SSLv3 read finished A
. 2011-11-09 09:23:42.281 Using TLSv1, cipher TLSv1/SSLv3: DHE-RSA-AES256-SHA, 1024 bit RSA
. 2011-11-09 09:23:42.286 SSL connection established. Waiting for welcome message...
> 2011-11-09 09:23:42.286 USER ***
< 2011-11-09 09:23:42.514 331 Password required for ***
> 2011-11-09 09:23:42.514 PASS *************
< 2011-11-09 09:23:42.592 230 User *** logged in
> 2011-11-09 09:23:42.592 SYST
< 2011-11-09 09:23:42.629 215 UNIX Type: L8
> 2011-11-09 09:23:42.629 FEAT
< 2011-11-09 09:23:42.657 211-Features:
< 2011-11-09 09:23:42.658 MDTM
< 2011-11-09 09:23:42.658 MFMT
< 2011-11-09 09:23:42.658 TVFS
< 2011-11-09 09:23:42.658 UTF8
< 2011-11-09 09:23:42.658 AUTH TLS
< 2011-11-09 09:23:42.658 MFF modify;UNIX.group;UNIX.mode;
< 2011-11-09 09:23:42.658 MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
< 2011-11-09 09:23:42.658 LANG en-US*
< 2011-11-09 09:23:42.658 PBSZ
< 2011-11-09 09:23:42.658 PROT
< 2011-11-09 09:23:42.658 REST STREAM
< 2011-11-09 09:23:42.658 SIZE
< 2011-11-09 09:23:42.658 211 End
> 2011-11-09 09:23:42.658 OPTS UTF8 ON
< 2011-11-09 09:23:42.690 200 UTF8 set to on
> 2011-11-09 09:23:42.690 PBSZ 0
< 2011-11-09 09:23:42.716 200 PBSZ 0 successful
> 2011-11-09 09:23:42.716 PROT P
< 2011-11-09 09:23:42.741 200 Protection set to Private
. 2011-11-09 09:23:42.742 Connected
. 2011-11-09 09:23:42.743 Got reply 1 to the command 1
. 2011-11-09 09:23:42.743 --------------------------------------------------------------------------
. 2011-11-09 09:23:42.743 Using FTP protocol.
. 2011-11-09 09:23:42.747 Doing startup conversation with host.
> 2011-11-09 09:23:42.754 PWD
< 2011-11-09 09:23:42.788 257 "/" is the current directory
. 2011-11-09 09:23:42.788 Got reply 1 to the command 16
. 2011-11-09 09:23:42.789 Getting current directory name.
. 2011-11-09 09:23:42.801 Retrieving directory listing...
> 2011-11-09 09:23:42.801 TYPE A
< 2011-11-09 09:23:42.826 200 Type set to A
> 2011-11-09 09:23:42.826 PASV
. 2011-11-09 09:23:42.826 m_pProxyLayer changed state from 0 to 1
< 2011-11-09 09:23:42.855 227 Entering Passive Mode (***).
. 2011-11-09 09:23:42.855 GetPeerName failed
. 2011-11-09 09:23:42.855 Could not retrieve directory listing
. 2011-11-09 09:23:42.855 Got reply 4 to the command 2
. 2011-11-09 09:23:42.865 Retrieving directory listing...
> 2011-11-09 09:23:42.865 TYPE A
< 2011-11-09 09:23:42.885 200 Type set to A
> 2011-11-09 09:23:42.885 PASV
. 2011-11-09 09:23:42.885 m_pProxyLayer changed state from 0 to 1
< 2011-11-09 09:23:42.923 227 Entering Passive Mode (***).
. 2011-11-09 09:23:42.923 GetPeerName failed
. 2011-11-09 09:23:42.924 Could not retrieve directory listing
. 2011-11-09 09:23:42.924 Got reply 4 to the command 2
* 2011-11-09 09:23:42.924 (ECommand) Error listing directory '/'.
* 2011-11-09 09:23:42.924 GetPeerName failed
* 2011-11-09 09:23:42.924 Could not retrieve directory listing
* 2011-11-09 09:23:42.924 Entering Passive Mode (***).
. 2011-11-09 09:23:43.002 Session upkeep
. 2011-11-09 09:23:43.051 Session upkeep
. 2011-11-09 09:23:43.494 Session upkeep
. 2011-11-09 09:23:43.745 Startup conversation with host finished.
. 2011-11-09 09:23:43.801 Session upkeep
. 2011-11-09 09:23:43.976 Session upkeep
. 2011-11-09 09:23:44.475 Session upkeep
. 2011-11-09 09:23:44.973 Session upkeep
. 2011-11-09 09:23:45.460 Session upkeep
. 2011-11-09 09:23:45.951 Session upkeep
. 2011-11-09 09:23:46.448 Session upkeep
. 2011-11-09 09:23:46.940 Session upkeep
. 2011-11-09 09:23:47.420 Session upkeep
. 2011-11-09 09:23:47.915 Session upkeep
. 2011-11-09 09:23:48.402 Session upkeep
. 2011-11-09 09:23:48.892 Session upkeep
. 2011-11-09 09:23:49.389 Session upkeep
. 2011-11-09 09:23:49.873 Session upkeep
. 2011-11-09 09:23:50.361 Session upkeep
. 2011-11-09 09:23:50.854 Session upkeep
. 2011-11-09 09:23:51.347 Session upkeep
. 2011-11-09 09:23:51.837 Session upkeep
. 2011-11-09 09:23:52.344 Session upkeep
. 2011-11-09 09:23:52.837 Session upkeep
. 2011-11-09 09:23:53.333 Session upkeep
. 2011-11-09 09:23:53.874 Session upkeep
. 2011-11-09 09:23:54.414 Session upkeep
. 2011-11-09 09:23:54.950 Session upkeep
. 2011-11-09 09:23:55.486 Session upkeep
. 2011-11-09 09:23:56.026 Session upkeep
. 2011-11-09 09:23:56.562 Session upkeep
. 2011-11-09 09:23:57.105 Session upkeep
. 2011-11-09 09:23:57.643 Session upkeep
. 2011-11-09 09:23:58.184 Session upkeep
. 2011-11-09 09:23:58.719 Session upkeep
. 2011-11-09 09:23:59.283 Session upkeep
. 2011-11-09 09:23:59.831 Session upkeep
. 2011-11-09 09:24:00.368 Session upkeep
. 2011-11-09 09:24:00.903 Session upkeep
. 2011-11-09 09:24:01.469 Session upkeep
. 2011-11-09 09:24:01.977 Session upkeep
. 2011-11-09 09:24:02.529 Session upkeep
. 2011-11-09 09:23:43.798 Disconnected from server


Do you have any idea why this happens?

Thanks!
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
pe wrote:
I have a similiar problem: initial directory listing after having connected over FTPS fails.
WinSCP runs in a Win7 VM on a Linux host. I'm behind a firewall. Therefore the host system tunnels traffic over SSH offering a local SOCKS5 proxy. WinSCP in the VM uses this proxy. FTP without SSL encryption works fine...

Are you able to do this with any other FTP client?
_________________
Martin Prikryl
newGuest01

Guest


Nettie wrote:
Those who say they cannot activate passive mode need to EDIT their already saved session. Or delete and create a new one if that is easier.

As stated in post above I was unable to access passive mode (grayed out) then after reading a previous post it explained to edit. Before this I was turning off my firewall and that worked. But choose passive mode instead.

Also these post really help so thank you.



None of the stuff on here worked in my case. I even downloaded the latest version of winscp with "passive" mode already checked. It only worked after I gave world execute permission on the directory. This sounds like a bug to me!
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
newGuest01 wrote:
None of the stuff on here worked in my case. I even downloaded the latest version of winscp with "passive" mode already checked. It only worked after I gave world execute permission on the directory. This sounds like a bug to me!

Please post a full log file showing the problem. Start a new topic for that.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
natasha

Guest


Can anyone tell me how to use Winscp as Ftp server???
Really urgent
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
natasha wrote:
Can anyone tell me how to use Winscp as Ftp server???
Really urgent

WinSCP is not FTP server.
_________________
Martin Prikryl
sago
[View user's profile]

Joined: 18 Oct 2012
Posts: 2
Location: Ukraine
Hi! After updating version 8,3,7 up to 5.1.0 gives out:
Error retrieving server address
Could not retrieve directory listing
Unable to build data connection: Operation not permitted
Thanks a lot!
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
sago wrote:
Hi! After updating version 8,3,7 up to 5.1.0 gives out:
Error retrieving server address
Could not retrieve directory listing
Unable to build data connection: Operation not permitted

Please attach a full log file showing the problem. Start a new thread for that.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl
Guest




prikryl wrote:
sago wrote:
Hi! After updating version 8,3,7 up to 5.1.0 gives out:
Error retrieving server address
Could not retrieve directory listing
Unable to build data connection: Operation not permitted

Please attach a full log file showing the problem. Start a new thread for that.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.


ok!
alfa@ftp.b2b.qiwi.ua.log (5.17 KB) [Download]

Description: (none)

prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
Thanks. Can you please also post a log file from 4.3.7?
_________________
Martin Prikryl
sago
[View user's profile]

Joined: 18 Oct 2012
Posts: 2
Location: Ukraine
prikryl wrote:
Thanks. Can you please also post a log file from 4.3.7?


ok!
alfa@ftp.b2b.qiwi.ua_ver4.3.7.log (4.15 KB) [Download]

Description: (none)

prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
Thanks for your report.
I have sent you an email with a development version of WinSCP to address you have used to register on this forum.
Piote

Guest


Hi.
In my case what helped was selecting "Use MLSD command for directory listing" from Auto to Off in FTP settings

Regards
prikryl
[View user's profile]
Site Admin
Joined: 10 Dec 2002
Posts: 19344
Location: Prague, Czech republic
Piote wrote:
In my case what helped was selecting "Use MLSD command for directory listing" from Auto to Off in FTP settings

Thanks for sharing your solution. Though, I would still like to see your session log file (in Auto mode).
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License