Topic "FAR + ConMan + WinSCP plugin in Vista x64 crash on F4"

Author Message
Tomzi

Guest


Hi!

I know, I know, I might be the only person on the planet with this problem, and my guess is that it's not a WinSCP plugin issue, nevertheless I thought I should inform you.

Thing is, I use FAR 1.70 (build 2087) with WinSCP plugin 1.6 beta and ConMan 2.35. When I use it on 32-bit XP it works fine, on Vista Business x64, however, it crashes whenever I press F4 on any file. Without either conman or WinSCP this bug doesn't present itself, I just can't have them both. It seems to me that ConMan and WinSCP don't like each other under Vista x64 (dunno about x86).

Things don't look bright for me if this is a ConMan bug, as ConMan doesn't seem to be alive anymore, last version is from 2005. Even though it's old, it's a very useful plugin, I don't think I could return to plain FAR anymore.

I'm sure you've got better things to do, but any chance of you looking into the matter?
Advertisements
Tomzi

Guest


Forgot to mention: all other plugins were removed, WinSCP 1.5.1 plugin produces the same error, and compatibility mode settings don't solve it.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
May I have your email email or alternatively, can you mail me? So I can send you a debug version eventually.
_________________
Martin Prikryl
Tomzi

Guest


Mail sent.
Tomzi

Guest


Tomzi wrote:
Mail sent.


I sent an e-mail to the address I found on http://www.prikryl.cz/eng/contact.php Hope you'll get it.
Maros Rajnoch

Guest


Hello all,

I have the same issue. I use:
far 1.70 build 2087
conman 2.32
winscpfar 1.60
MS WIN Vista 64-bit

when selecting winscp pluggin, the FAR is going down. maybe there's some kind of DEP issue. Sometimes the FAR is going down while starting.

BTW: Tomzi, where did you get conman version 2.35?
Tomzi

Guest


Sorry, my mistake. I'm using ConMan 2.32 too. Thanks for pointing that out.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Tomzi wrote:
I sent an e-mail to the address I found on http://www.prikryl.cz/eng/contact.php . Hope you'll get it.

I have already replied, sorry for delay.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
This issue has been added to tracker.
_________________
Martin Prikryl
Tomzi

Guest


Aren't bug 158 and bug 157 the same?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Tomzi wrote:
Aren't bug 158 and bug 157 the same?

Sure. Thanks Smile
_________________
Martin Prikryl
jmanungu

Guest


If you are still having trouble to get your WinScp work in vista 64 bit resolution, there is a recommendable version that you can download at: http://www.oldapps.com/WinSCP.php?old_winscp=23 which have 32 and 64 bits resolution.

Joseph M.

Tomzi wrote:
Forgot to mention: all other plugins were removed, WinSCP 1.5.1 plugin produces the same error, and compatibility mode settings don't solve it.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
jmanungu wrote:
If you are still having trouble to get your WinScp work in vista 64 bit resolution, there is a recommendable version that you can download at: http://www.oldapps.com/WinSCP.php?old_winscp=23 which have 32 and 64 bits resolution.

Do not use these. Too old and too buggy.
_________________
Martin Prikryl
Px

Guest


Problem become bigger under Windows 7 x64, now Far under Conman closes on launch, if WinSCP plugin is presented. After one launch Far without Conman, you can start Far under Conman, but it still crash in editor
PS: what progress on native version under Far 2.0? Smile
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Px wrote:
PS: what progress on native version under Far 2.0? Smile

No progress yet Sad
_________________
Martin Prikryl
Px
[View user's profile]

Joined: 2009-12-23
Posts: 6
prikryl wrote:
Px wrote:
PS: what progress on native version under Far 2.0? Smile

No progress yet Sad

Sad
May I ask - why?
Pascal/Delphi headers available for a while, one of the plugin developers ported almost all his plugins from ansi to unicode, and even made x64 versions with Free Pascal Compiler. His sources available here - http://code.google.com/p/far-plugins/source/browse/#svn/trunk
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Px wrote:
May I ask - why?

Lack of time.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License