Topic "winscp fails to read directory list"

Author Message
mclauss

Guest


WinSCP fails to get the filelist of a remote directory. The server does for "ls -la" precede the file list with a summary line, and winscp stumbles over it. What can I do? Is there a configuration option to give ls some other options?

The listing from the server is as follows:

remotehost /home/mclauss> ls -la
insgesamt 214
drwxr-x--- 8 mclauss users 1125 Mai 31 2006 .
drwxr-xr-x 24 root root 553 Sep 27 07:15 ..
-rw-r----- 1 mclauss users 5742 Apr 4 2002 .Xdefaults
-rw-r----- 1 mclauss users 1305 Apr 4 2002 .Xmodmap
Advertisements
mclauss

Guest


I Forgot:
WinSCP v 4.07 (Build 370)

Error from WinSCP is:
Unexpected directory listing line 'insgesamt 214'.
Invalid rights description 'nsgesamt '
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
WinSCP requires English environment with SCP protocol. So you have an option Clear national variables enabled? Have you tried using SFTP instead of SCP?
_________________
Martin Prikryl
mclauss

Guest


Ok, thank you very much!

For a local shell I managed to get the responsible environment variable removed. With that, 'ls -la' does print 'total nnn' as first line. I guess WinSCP knows this and can proceed.

So I just don't found out how to do removing this variable with the shell WinSCP opens. Is there any option for that?
Otherwise - i don't know how. I have a tcsh for my user, running on an older SuSE Linux.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
mclauss wrote:
So I just don't found out how to do removing this variable with the shell WinSCP opens. Is there any option for that?

Which variable it is?
_________________
Martin Prikryl
mclauss

Guest


It is:
LANG=de_DE@euro

When I clear it / set to empty string,
the result os ls -la is like:
total 214
drwxr-x--- 8 mclauss users 1125 Mar 12 14:39 .
drwxr-xr-x 24 root root 553 Sep 27 07:15 ..
-rw-r----- 1 mclauss users 5742 Apr 4 2002 .Xdefaults
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
WinSCP by default calls "unset LANG" on startup. Unless you have disabled it on the login dialog. Or do you need to use different command to unset a variable?
_________________
Martin Prikryl
mclauss

Guest


Hi,
when I change my account settings to have a bash, it works fine (winscp does unset it bash understands it).
With my default tcsh it does not work, it ignores the unset command.
I had to execute "setenv LANG=" to get it cleared, found no other way.

Thanx for your help!

Would you like to open winscp for other shells?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
mclauss wrote:
Would you like to open winscp for other shells?

No. But you do not have to change a default shell of your account. You can set WinSCP to use non-default shell. Please read documentation.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License