Topic "Disconnected from server - Connection timed out."

Author Message
Ricoman
[View user's profile]

Joined: 2008-11-19
Posts: 9
Hi,

Thanks for the great work on this program.
However, the dropped connections are really bugging me.
At first I had Keep-Alive enabled, but I still kept getting disconnected from the server. This happened every 5 minutes or so. (The server is filezilla server). I noticed that the server had a 600 second timeout on file transfers. I disabled this timeout, and turned off Keep-Alive.
Now I keep getting the following error:
Disconnected from server
Connection timed out.

Is this a timeout in WinSCP or on the server? As far as I know, the server should not be timing out. If it is in WinSCP, how can I change it?

I realize that a lot of great work has gone into this program, but I can't imagine how anyone can put up with having to click "Reconnect" every 5 minutes. I'm utterly surprised that there isn't an automatic silent reconnect. Or that at the very least you could do away with that bothersome Reconnect dialog box so that someone can keep working (e.g. with the local pane) and then only reconnect when they need to. As it is, they have to either reconnect over and over again or choose to not reconnect, in which case the view of the remote window is lost, so the user can't do any comparisons of the cached directories.

Thanks very much!!
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
When do you get the error?
Ricoman
[View user's profile]

Joined: 2008-11-19
Posts: 9
I'm not entirely sure when I get the 'disconnected' message or why.
It seems to happen in response to WinSCP trying to keep the remote view refreshed periodically. The message does NOT appear in response to anything I am doing (at least I don't think it does). For example, I connected to the remote server, and then I was just looking at the list of files on the remote server and the local server. I was scrolling down though each list, but I was not refreshing the views or initiating any transfers. I may have switched between other programs running at the same time (but only one instance of WinSCP was open).
I kept getting interrupted by the "disconnected" errors periodically, and I had to click "reconnect" or I would lose the remote view. I wish that WinSCP did not show that dialog box. It could just list the disconnected event in the log. Then if I want to refresh the view or initiate a transfer, WinSCP should automatically reconnect and open to the same folders that are currently shown. (This is the behavior that FileZilla uses, for example).
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Please post a log file.
_________________
Martin Prikryl
Sim

Guest


I have the same problem using FTP connections.
I can't set off of keepalives setting for connections. This option are not saved.
I think if I set keepalives off it will resolve the problem, but I can't do this.

error from log file:
Quote:
. 2009-06-23 06:36:52.784 Cached directory change via "records" to "/records".
. 2009-06-23 06:36:52.784 Getting current directory name.
. 2009-06-23 06:36:52.800 Retrieving directory listing...
> 2009-06-23 06:36:52.800 CWD /records/
< 2009-06-23 06:36:52.800 250 CWD command successful
> 2009-06-23 06:36:52.800 PWD
< 2009-06-23 06:36:52.800 257 "/records" is current directory.
> 2009-06-23 06:36:52.800 TYPE A
< 2009-06-23 06:36:52.800 200 Type set to A
> 2009-06-23 06:36:52.815 PORT 89,187,36,2,10,65
< 2009-06-23 06:36:52.815 200 PORT command successful
> 2009-06-23 06:36:52.815 LIST -a
< 2009-06-23 06:36:52.831 150 Opening ASCII mode data connection for file list
. 2009-06-23 06:36:52.987 Timeout detected.
. 2009-06-23 06:36:52.987 Could not retrieve directory listing
. 2009-06-23 06:36:52.987 Got reply 1004 to the command 2
* 2009-06-23 06:36:52.987 (ESshFatal) Lost connection.
* 2009-06-23 06:36:52.987 Timeout detected.
* 2009-06-23 06:36:52.987 Could not retrieve directory listing
* 2009-06-23 06:36:52.987 Opening ASCII mode data connection for file list
* 2009-06-23 06:36:52.987 Error listing directory '/records'.
* 2009-06-23 06:36:52.987 Error changing directory to 'records'.


Also WinSCP plugin don't view hidden files on the server like ".htaccess". Why?
Sim
[View user's profile]

Joined: 2009-06-23
Posts: 8
I understend about hidden files.
Sim
[View user's profile]

Joined: 2009-06-23
Posts: 8
prikryl,
Do you plan to fix this bug with often connection lost error?
I think WinSCP must auto reconnect to server if any connection error occured.
Or it must nothing to do (no any error messages, and do not switch panel to HDD) and reconnect when user do any action that need this connection.

When this fix will be done?
Thank you.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Sim wrote:
prikryl,
Do you plan to fix this bug with often connection lost error?
I think WinSCP must auto reconnect to server if any connection error occured.
Or it must nothing to do (no any error messages, and do not switch panel to HDD) and reconnect when user do any action that need this connection.

Thanks for your post. This issue is being tracked already.
_________________
Martin Prikryl
Sven

Guest


Same Problem with my WinSCP. Sometimes it losts the connection 3 to 4 times a minute. Sometimes it runs a few Minutes without a Problem. Its hardly to reconnect by button everytime. Once its a "timeout", next is "connection lost", and more Failure Popoups. I cant see any logical Issue for that. WinSCP is great, but the permanently need to press "OK" or "Reconnect" really kills my nerves. I tested a few different preferences with the connection but allover the same problem.
Sim
[View user's profile]

Joined: 2009-06-23
Posts: 8
prikryl wrote:
Sim wrote:
prikryl,
Do you plan to fix this bug with often connection lost error?
I think WinSCP must auto reconnect to server if any connection error occured.
Or it must nothing to do (no any error messages, and do not switch panel to HDD) and reconnect when user do any action that need this connection.

Thanks for your post. This issue is being tracked already.


I see that in WinSCP 4.2.2 this bug was fixed, but what about Far plugin?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Sim wrote:
I see that in WinSCP 4.2.2 this bug was fixed, but what about Far plugin?

First, it's not a bug.
The change will get into FAR plugin once. I cannot tell when.
_________________
Martin Prikryl
Sim
[View user's profile]

Joined: 2009-06-23
Posts: 8
prikryl wrote:
The change will get into FAR plugin once. I cannot tell when.

Please do it, we all (Far+WinSCP users) need it for normal work.
2137

Guest


Does this quirk (since you disapprove of calling it a bug) still persist in 4.1.9, or must I make use of the 4.2.2 beta?

Thanks for a great portable program!
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
This was implemented only in 4.2.2 as you can see in the tracker.
_________________
Martin Prikryl
BRix

Guest


I experiencing a "PAGE NOT FOUND @ one of the game site we play in the shop and we couldn't connect to the server even were already updated and played for almost a months when suddenly one morning we encounter that we couldn't connect to the game. I already done something but still e could not make it.. even the game site banner saying "Page not found" what could be the problem?
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License