Topic "Encryption Reverts To Default AES"

Author Message
Audrey Clement
[View user's profile]

Joined: 2009-01-06
Posts: 1
WinSCP Version 4.1.8 Build 415
When I change encryption policy to 3DES and store the session information, I can log onto my host. However, when I exit WinSCP and start a new session, WinSCP reverts back to the default AES, as a consequence of which my host apparently does not recognize my login information and denies me access.

This is very frustrating. Here's hoping you will fix.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
I'm not able to reproduce this.

What I did:

Start WinSCP
Stored sessions tab shows
Click New
Type in Host name, User name and Password
Select SSH tab
Select 3DES cipher
Press Up twice to get 3DES to the top
Click Save..., type in session name
Login
After login select Commands > Server/protocol Information
"3des" encryption algorithm shows
Exit WinSCP
Start WinSCP
Select previously saved stored session
Click Edit
Select SSH tab
3DES is on the top
Click Login
After login select Commands > Server/protocol Information
"3des" encryption algorithm shows
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
Also can you post a log file?
_________________
Martin Prikryl
AClement

Guest


I tried unsuccessfuly to replicate the problem again and learned that after highlighting a stored session name in WinSCP, you must also click the Edit command or the protocol displayed under the SSH tab will revert to the default.

Clicking the stored session name followed by the Edit command will show the protocol stored with the session. Since there is no problem with WinSCP per se, my logon difficulties were on the host end. However, it might be helpful in future versions for WinSCP to display stored session settings accurately regardless of whether the Edit command has been invoked.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
AClement wrote:
I tried unsuccessfuly to replicate the problem again and learned that after highlighting a stored session name in WinSCP, you must also click the Edit command or the protocol displayed under the SSH tab will revert to the default.

Unless your click Edit all options keep their default value. Not only options on SSH tab.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License