Topic "/defaults option not working on command line"

Author Message
rch
[View user's profile]

Joined: 2009-03-19
Posts: 1
when entering /defaults at end of command line winscp scp string get weird windows dialog error message about including URL and after clicking that off session runs but dialog to copy appears anyway as if in gui session.. Other than that the command line for scp with multiple files works..

with popup dialog though would not be able to run via windows scheduler of course which is main problem..
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
The weird dialog actually explains you what's wrong. You cannot use URL-like session specification (e.g. sftp://user@server) together with /detauls.

Nevertheless using WinSCP tike this from scheduler can hardly work reliable. Use scripting instead. This FAQ may help you.
_________________
Martin Prikryl
Vivi

Guest


Hi Martin,

while running command line parameters, the upload works fine. (unable to use /defaults though)
But when i try to use scripting/commands as "open user:pass@ip" it reads "open user" as the session name and throws an error. Am i missing something trivial here
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
Full example of command line you are using would help.
Though you seem to combine operations command-line parameters with scripting.
What are you trying to do?
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License