Topic "Host in not communicated for more than 15 seconds"

Author Message
Guest




winSCP message "Host in not communicated for more than 15 seconds."

where I may turn off this meggase and make auto-reconnect?
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
You cannot.
When do you get the message?
_________________
Martin Prikryl
Guest




I try to upload 30-40 files(100-1000 mbytes) in quere/background.

I think, host loosing connection with remove server then my internet connection have a some trouble, and WinSCP did't make auto-reconnect(somethimes or anywere). I must click button "abort" on this message to make re-connect and upload more.

Message "Host has not answered for more than 15 seconds. still waiting. Warning: aborting this operation will close connection" and button "Abort" for 4.1.8
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Well WinSCP does not do autoreconnect because the connection was not lost.
_________________
Martin Prikryl
Guest




but in this situation, winscp did't upload more files. Maybe, change something-for example:
Reconnect(after X seconds of not answered)
or timeout.
or auto-ignore this message and upload more.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
This request has been added to tracker.
_________________
Martin Prikryl
Guest




I'm also having a problem with this, it occurs due to a bad connection with the server. I would rather not have the extra prompt for my scripting.
JJMinero

Guest


I had the same problem of 15 sec.
the problem was that i was trying to connect Winscp to an FTP direction and it was missing to especify that it was a FTP connection instead of a SSH connection.

At the end the bat file is this one:
C:\ftp\winscp419.exe /console /script=C:\ftp\put.txt /log=C:\ftp\log.txt
pause

and the put.txt is this one:

option batch on
option confirm off
open FTP://user:password@IP:PORT
cd /out
option transfer binary
put c:\ftp\asdf.txt
close
exit

I hope it help to some one
Wamiduku
[View user's profile]

Joined: 2010-02-16
Posts: 3
Location: Sweden
Same problem here. I have to manually reconnect. Enabling WinSCP to do this automatically would be a great help!
Vielheit

Guest


I get this message regularly with dreamhost. This is very annoying cause it is stopping the transfer queue. Please implement a stupid retry mechanism for unattended usage.
bobmane
[View user's profile]

Joined: 2011-07-11
Posts: 2
i got the message when selecting my entire directory (about 2GB) and choosing tar/gzip

once i make the command nothing happens for several seconds > then the message pops up > then I cancel out of dialog window

but the file was created anyway

I guess that means it is either happening after the zip takes place or during in which case I cant be sure I got 100% zip. suppose i will have to compare file sizes to be sure
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
bobmane wrote:
i got the message when selecting my entire directory (about 2GB) and choosing tar/gzip

once i make the command nothing happens for several seconds > then the message pops up > then I cancel out of dialog window

but the file was created anyway

I guess that means it is either happening after the zip takes place or during in which case I cant be sure I got 100% zip. suppose i will have to compare file sizes to be sure

Just do not cancel it and wait until it disappears on its own.
_________________
Martin Prikryl
guest

Guest


in my case the message never goes away i have to abort manually. very annoying for long transfers.
phpJoel

Guest


Changing directories often requires me to reconnect lately.. on any server.

Win7 64bit
WinSCP latest stable
gummyrat

Guest


I can confirm that this happens frequently with Dreamhost. When I don't react to the prompt, it does go away but the transfer doesn't resume, it is stuck with a question mark next to it. When I hit "Abort", the transfer resumes immediately.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
gummyrat wrote:
I can confirm that this happens frequently with Dreamhost. When I don't react to the prompt, it does go away but the transfer doesn't resume, it is stuck with a question mark next to it. When I hit "Abort", the transfer resumes immediately.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl
SHOOTDAZOMBIE!

Guest


i keep seeing cannot remove on the left of terminal???
please help
nagaraju

Guest


you can use the SCP connnection in winscp while copying,then this error wont comes.
Pankaj Patel

Guest


Hi,

I have downloaded latest build version of WinSCP 5.5.5 and after trying to connect SFTP server getting message saying "Host is not communicating for more then 15 seconds. still awaiting", try turning off 'Optimize connection buffer size", i tried turn off "Optimize connection buffer size" but message is still appear.

Interesting part is,sometime i can able to connect it, but sometime not.

Does someone help me out to resolve this issue?

[/img]
smitty123
[View user's profile]

Joined: 2014-10-26
Posts: 36
Location: Canada
hello all, new here

i have the same problem but when duplicating big files (500mb+) on the remote server. Not copying from local to server and i may have a simple solution to this problem.

ok, so i want to copy/duplicate files from hdd2 to hdd1 on my nas. i right-click a folder, duplicate, then enter the path to the other hdd and press enter to start. Winscp logs in and sends the command to the server.

Winscp waits then i get the timeout popup after 10seconds. the duplication window doesn't even come up until that one does (which is strange in itself).

Looking at the log created by winscp (attached), winscp issues the cp command with -p -r -f to the server.

What if adding the -v (verbose) switch to it might solve this timeout ?


Winscp would hear back from the server as it does the file copy. So large file timeouts could get resolved and winscp could update its progress bar as it received verbose info from cp.

Using the server's web interface i can see the cp process in memory. And files do get duplicated.

Adding the verbose switch to the issued cp command might help.

As for the duplicate dialog window not appearing, idk why but it doesn't pop up until the timeout dialog box does over it.


Hope this helps. take care,
Smitty
admin@server.log (18.12 KB) Private file

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
smitty123 wrote:
What if adding the -v (verbose) switch to it might solve this timeout ?


Winscp would hear back from the server as it does the file copy. So large file timeouts could get resolved and winscp could update its progress bar as it received verbose info from cp.

Thanks for the suggestion. Will consider it.

Quote:
As for the duplicate dialog window not appearing, idk why but it doesn't pop up until the timeout dialog box does over it.

Thanks for your report.
I have sent you an email with a development version of WinSCP to address you have used to register on this forum.
João Rodrigues

Guest


Hello,
I'm facing the same problem here. The winscp stops retrying sending the file after 15 seconds of a connection lost?
the "option reconnect 120" does not work in here.

After so manny years the problem remains?

Best regards.
Guest




This issue was not resolved yet.
smitty123
[View user's profile]

Joined: 2014-10-26
Posts: 36
Location: Canada
João Rodrigues wrote:
Hello,
I'm facing the same problem here. The winscp stops retrying sending the file after 15 seconds of a connection lost?
the "option reconnect 120" does not work in here.

After so manny years the problem remains?

Best regards.


What i ended up doing is 2 things, 1st change the timeout of connection to 6000, that's gonna be long enough to complete any task. you'll find this in the advanced settings of your connection's login profile.

2nd i started using the "File station" (web interface) that comes with my nas for big file transfers.

Use the right tools for the job you need to do.

cheers
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License