Topic "Rights of edited files change"

Author Message
mike2009

Guest


I'm using 4.1.8. to connect from WinXP to SuSe-Server (root-user).

When I open a file (text based) with internal editor and save this file back, the granted rights change to 644 (instead former 755).

i found settings to force pre-defined permission to uploaded files.
This option is un-checked.

I also tried to delete the registry-key "text" without success.

This - I call it bug - is new. Former versions didn't change permissions of files.

Any workaround ?

Thanks
Mike
Advertisements
Guest




add:

the owner and group is also changed to logged user (i.e. root root).
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
This article partially explain the issue.

However please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl
mike2009

Guest


Hello,

sorry, I can't post a logfile, because I go down to 4.1.5 (B410), because there is everything correct (working).

But your advised article doesn't describe the problem.

In option-dialog -> transfer you have the possibility to define permission for transferred/new files.
In 4.1.5 you leave this option unchecked, then everything works fine.

In the act. version there is no matter this option is checked or not - the "pre-defined" permission 644 is given to ALL files, no matter to whom they belong or whatever permission was before "overwriting".
So I think, this option is not correct implemented in workflow.
Also very strange: the ownership (owner/group) of the new or overwritten file changes to actual user. This option - I can not find it - belongs to no customer configuration posibility.

Even there is no difference, when I check the mask, i.e. 777, the result is also 644. Even if I delete the corresponding registry-key (also tried to save config in file not in registry) does not bring any other result.

I saw that this "bug" only appears working as root. Other users don't have this problems.

If you think a logfile will be helpful to solve this tricky problem, I can install act. version on an other machine and try it out.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
mike2009 wrote:
sorry, I can't post a logfile, because I go down to 4.1.5 (B410), because there is everything correct (working).

Hm, there were no relevant change between 4.1.5 and 4.1.8.

Quote:
If you think a logfile will be helpful to solve this tricky problem, I can install act. version on an other machine and try it out.

It would, please do.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License