Topic "Remote Permission setting fails"

Author Message
_Andrej_

Guest


I can't set permissions on my remote directories. The error code is:

Command "chmod u+rwx,g+rx-w,o+rx "kepek""
failed with return code -1 and error message
invalid characters in scp command!
here:+rwx,g+rx-w,o+rx "kepek"
try using a wildcard to match this file/directory.

I hope you know why this happens. The server setting is SCPonly.

Thank you for your help
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Your SCPonly shell does not support +/- syntax of chmod or chmod command at all. It the first is true, you may try to specify permissions exacly (all checkboxes must be on or off, none must be "undefined"). In this case WinSCP uses octal format of chmod. This feature is supported only by latest build of WinSCP.
_________________
Martin Prikryl
_andrej_

Guest


Thx, I will look after it, now. Smile

It works fine now... I don't know what was the problem, I did the permission setting the same way both times.

Anyway, thank you for your help!
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License