Topic "Set permissions & new files/directories"

Author Message
elephantman

Guest


I've been using the "Set permissions" option so that files are uploaded as 0664 and directories as 0775. The problem is that when I create a file or directory (by right clicking and selecting new -> file/directory) the newly created file/directory has the default permissions (0644/0755). Am I missing something? I use WinSCP 4.1.9 and connect via the SFTP v3 protocol.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
Make sure you press More button on create directory dialog.
_________________
Martin Prikryl
fnf

Guest


Can someone explain to me as a newby how to utilize this upload options feature, to set all uploaded files to 644 and all uploaded directories to 755?

It looks like it's set default to rw-r--r-- (+x) and then inside has the option to add X to directories.

Is this good to go as is? It just needs to be ticked at Set Permissions? Or do I have to change or add anything out front?

Sorry about my ignorance. I'm learning. And thank you in advance for any help.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
It should works as such with the default settings you mention. Just make sure Set Permission is selected.
_________________
Martin Prikryl
CJ7

Guest


prikryl wrote:
Make sure you press More button on create directory dialog.


Yes but what about for creating a new file? There is no way to set the permissions when you create a new file. It gets created with 644 permissions and then you have to change the permissions to what you want.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
CJ7 wrote:
Yes but what about for creating a new file? There is no way to set the permissions when you create a new file. It gets created with 644 permissions and then you have to change the permissions to what you want.

You can configure the default permissions of uploaded files in Preferences:
https://winscp.net/eng/docs/ui_pref_transfer
Hauthorn_05

Guest


Can't get the Set Permissions checkbox to apply to newly created files. My process is right-click -> new file, ALL of my modes in the Transfer settings are Set Permissions (checked) to 755.

New files do not come in with these changes.

Can't decide if it doesn't work or if I'm not doing it "right".

Step by step what-to-click-when-making-new-file instructions would be appreciated, 'cause I'm unable to get WinSCP settings to function.

Thanks.
screenies.png (117.21 KB) [Download]

Description: (none)

Hauthorn05

Guest


Disregard my post!

I learned the issues are with sftp and not my actions through ftp clients.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License