Topic "TLS over FTP Passive Issue"

Author Message


First the facts:
Winscp ver 4.2.1(build 428)
Windows Vista 64bit
FTP with TLS explicit encryption
Using GUI

The short error message:
Timeout detected.
Could not retrieve directory listing
Entering Passive Mode (192,168,83,20,17,132)
Error listing directory '/'.

The log:

My story:
I am connecting to a remote ftp server and was connecting but the server was refusing to list the directory. It looked like it was an issue with my router being that it refused to communicate with my local IP and would only connect to my WAN IP. So I switched it over to passive mode and still failed to connect. The ftp server is running passive mode on ports 4500-4600. After scratching my head for nearly 2 hours I decided to give in to my friend's demands that I try filezilla. So I tried it (knowing full well there would be no difference) and it worked. I cannot tell you how furious I was. I promptly uninstalled Filezilla for its impudence.

But what could be causing this?
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24759
Location: Prague, Czechia
It can be possibly caused by this issue. What do you think?

You can post new topics in this forum

Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License