Topic ""Keep remote dirs up to date" uploads everything twice"

Author Message
Henrik
[View user's profile]

Joined: 2009-09-05
Posts: 7
Location: Toronto
All,

I use Notepad++ for my code editor, but instead of using its FTP connect product (flaky, in my experience destructive), I use WinSCP's "Keep remote directories up to date" command. Works great.

But for some reason whenever this command updates the remote directory, it uploads the changed file twice. Not a huge deal, but some of my code files are large enough that this causes a few seconds of delay whenever I save changes to a file.

Am I missing something? Have I set something that should be unset?

Thanks,

- Henrik
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Well, notepad may trigger two "change" events. This is very common. Though WinSCP should ignore the latter one because the files are already synchronized after the first upload. As it does not, it looks like general problem with timestamps synchronization. Check if the timestamp of remote file is the same as timestamp of original local one. If they are not, refer to this FAQ.
Henrik
[View user's profile]

Joined: 2009-09-05
Posts: 7
Location: Toronto
Thanks much Prikryl.

The time stamp on my server is time-zone adjusted, and therefore files on the server are stamped 3 hours *before* mine. Thus perhaps WinSCP synchronizes owing to the earlier time on the server?

Is there a way to tell WinSCP to take time zones into account?

Thanks so much for your product. It's a lifesaver...

- Henrik
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Please read documentation. If that does not help, come back.
_________________
Martin Prikryl
Henrik
[View user's profile]

Joined: 2009-09-05
Posts: 7
Location: Toronto
Thanks Martin,

The Timezone offset field is disabled, although I am using the FTP protocol (that's for the server in question - I have a stored session for a different server using SFTP).

I have tried to both set and unset preserve remote timestamp, with no change in enabling the field.

- Henrik
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Henrik wrote:
The Timezone offset field is disabled, although I am using the FTP protocol

Make sure you actualy select FTP on Session tab before you go to Environment tab.
_________________
Martin Prikryl
Henrik
[View user's profile]

Joined: 2009-09-05
Posts: 7
Location: Toronto
Thanks Martin,

I changed the setting in the saved session (as opposed to the login screen), and that worked.

All good.

Thanks again.

Best,

- Henrik
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License