Topic "-delete causing option exclude to be ignored"

Author Message
WeZ

Guest


Hello,

using this code:
Code:

option exclude "*/; zzz"
get *.* D:\BACKUP\Afrox\Afrox_Downloaded_Files\20091201\
quit


Winscp downloads all the files in the root directory and ignores the sub-directory as well as the file called "zzz" (don't ask Smile)

If i add the -delete option:
Code:

option exclude "*/; zzz"
get *.* D:\BACKUP\Afrox\Afrox_Downloaded_Files\20091202\ -delete
quit


It ignores the option exclude values and moved the sub-directories as well as the "zzz" file.

Please can someone help me here?

Ciao
WeZ
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
That's by design. See documentation.
_________________
Martin Prikryl
Guest




prikryl wrote:
That's by design.


Thanks Martin for pointing it out (although i cant think of why it should be designed as such) - but it still doesn't help me.

How do I stop this application from removing the sub dirs and the zzz file as displayed in my option exclude statement??

Ciao
WeZ
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Anonymous wrote:
How do I stop this application from removing the sub dirs and the zzz file as displayed in my option exclude statement??

You will need to use some more complex scripts. Sch as listing files to transfer first and then download and delete them one by one. Example scripts may give you some hints.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License