Topic "synchronised browsing bug"

Author Message
TimBenjamin

Guest


I have recently upgraded to 4.2.5 from (I think) 4.1.x

Synchronised browsing no longer seems to work correctly. For example, I have the local directory set to C:\Work\SiteName\www and the remote directory set to /var/www/html/sitename

The contents of those two directories are identical.

Turning on synchronised browsing, with the local and remote directories set to those given above, and then attempting to browse to C:\Work\SiteName\www\docroot (for example) I get the following message:

Quote:
Error changing directory to '/var/www/html/www/docroot'
Cannot get real path for '/var/www/html/www/docroot'
No such file or directory.
Error code: 2
Error message from server: No such file


Obviously, it should be trying to change to '/var/www/html/sitename/docroot' not '/var/www/html/www/docroot' - it replaces 'sitename' with 'www', and that is the bug I want to report.

I have tried various different paths in the "Directories" section of the session setup screen but to no avail. Clearly WinSCP is mapping the directories incorrectly, and it didn't do this before.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
_________________
Martin Prikryl
TimBenjamin
[View user's profile]

Joined: 2010-01-22
Posts: 1
Email sent.
Rhialto
[View user's profile]
Donor
Joined: 2009-11-02
Posts: 24
Location: Québec, QC - CANADA
Same here, I recently upgraded to 4.25 and found that bug so I'm back with 4.24 beta and all is fine. I use the portable version.

When we double-click in the right pane (remote) sync works and the left pane follow.
It's when we double-click in the left pane that the sync does not work and we get the error.

Just curious, why this was working in all previous versions then suddenly stop to work? Introduction of a new feature maybe?

Last edited by Rhialto on 2010-01-25 19:46; edited 1 time in total
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Rhialto wrote:
Same here, I recently upgraded to 4.25 and found that bug so I'm back with 4.24 beta and all is fine. I use the portable version.

When we double-click in the right pane (remote) sync works and the right pane follow.
It's when we double-click in the left pane that the sync does not work and we get the error.

Will send you a debug version.

Quote:
Just curious, why this was working in all previous versions then suddenly stop to work? Introduction of a new feature maybe?

Correct. Synchronized browsing in 4.2.5 works even when changing to different directory branch in one step.
_________________
Martin Prikryl
Rhialto
[View user's profile]
Donor
Joined: 2009-11-02
Posts: 24
Location: Québec, QC - CANADA
oops, I edited my message to cerrect that line:

When we double-click in the right pane (remote) sync works and the left pane follow.

Have you tried it youself? It's when we double-click in the left pane that the error happen...
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
This bug is being tracked.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License