Topic "File Name Corruption on transfer to windows"

Author Message
mikewill34
[View user's profile]

Joined: 2010-05-13
Posts: 3
Location: Leicester, UK
Hi,

Using WinSCP Version 4.2.7 build 758

When the "Transfer" "Filename modification" Option Replace \:*?'... is checked some uppercase letters "A", "F", "R" & "S" are wrongly escaped to %XX. See examples below.

Unix FileName(s)
Code:
A B C D E F G H I J K L M.txt
N O P Q R S T U V W X Y Z.txt
are wrongly converted to :-
Code:
%41 B C D E %46 G H I J K L M.txt
N O P Q %52 %53 T U V W X Y Z.txt

i.e.
A --> %41
F --> %46
R --> %52
S --> %53

This occurs when transfering from a Unix host to windows.

Regards
Mike
Advertisements
mikewill34
[View user's profile]

Joined: 2010-05-13
Posts: 3
Location: Leicester, UK
Hi Martin,

Problem still exists in debug version.
I have emailed you a link to get the log files and screen shots




Regards
Mike
mikewill34
[View user's profile]

Joined: 2010-05-13
Posts: 3
Location: Leicester, UK
Hi Martin,

Thanks for your help, my .ini file had several corrupted areas as follows:-
Code:
L = New .ini file
R = Corrupted ini file
------------------------------------------------------------------------
L26  PuttySession=WinSCP%20temporary%20session
     PuttyPath=%25PROGRAMFILES%25%5CPuTTY%5Cputty.exe
R36  PuttySession=WinSCPR0temporaryR0session
     PuttyPath="C:%5CProgram%20Files%5CPuTTY%5Cputty.exe"
------------------------------------------------------------------------
L52  SelectMask=%2A.%2A
R62  SelectMask=RA.RA
------------------------------------------------------------------------
L97  Masks=%2A.%2Ahtml;%20%2A.htm;%20%2A.txt;%20%2A.php;%20%2A.php3;%20%2A.cgi;%20%2A.c;%20%2A.cpp;%20%2A.h;%20%2A.pas;%20%2A.bas;%20%2A.tex;%20%2A.pl;%20.htaccess;%20%2A.xtml;%20%2A.css;%20%2A.cfg;%20%2A.ini;%20%2A.sh;%20%2A.xml
R107 Masks=RA.RAhtml;R0RA.htm;R0RA.txt;R0RA.php;R0RA.php3;R0RA.cgi;R0RA.c;R0RA.cpp;R0RA.h;R0RA.pas;R0RA.bas;R0RA.tex;R0RA.pl;%20.htaccess;R0RA.xtml;R0RA.css;R0RA.cfg;R0RA.ini;R0RA.sh;R0RA.xml
------------------------------------------------------------------------
L107 LocalInvalidChars=/%5C:%2A%3F"<>|
R117 LocalInvalidChars=/%5C:RASF"<>|
------------------------------------------------------------------------
L179 LastLocalTargetDirectory=C:%5CUsers%5COwner%5CDocuments
R235 LastLocalTargetDirectory=C:UCUsersE5COwnerUCDocuments
------------------------------------------------------------------------
L220 FileMask=%2A.%2A
R276 FileMask=RA.RA
------------------------------------------------------------------------
L228 FileMask=%2A.%2A
R284 FileMask=RA.RA
------------------------------------------------------------------------


I deleted the old ini file and let WinScp create a new one.

Regards
Mike
sduarewe122

Guest


How this prob is solved?
I cannot locate the .ini file also
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24553
Location: Prague, Czechia
sduarewe122 wrote:
How this prob is solved?
I cannot locate the .ini file also

Yes, it was resolved as described above. If you do not have INI file, you may have registry configuration corrupted.
See http://winscp.net/eng/docs/config
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License