Topic "file uploaded succesfully, but unable to set permissions...."

Author Message
bilbo6209

Guest


I have set up a simple cmd script to run a scheduled back up for a client (using windows task scheduler to launch the CDM). Everytime teh script runs it throws up a message stating "Upload of file <filename> was successful, but error occurred while setting the permissions and/or timestamp"

I have changed the option to not report permissions errors, I have tried every combination of checked and unchecked for every timestamp and permissions I can find in the configuration.

the CMD script is teh following ""C:\Program Files\WinSCP\WinSCP.exe" /defaults /synchronize "C:\backup" "/backup/"" all the connection info is saved in the profile along with all the settings for setting permissions and time stamps.

Any thoughts or pointers for this would be great! I have 2 users set up on 2.7 and they do not seem to have this issue, but the 2 users who are set up on 2.8 have this issue with every synch Sad
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
When synchronizing the timestamp is updated always, disregarding the settings, because the synchronization does not make sense otherwise.
_________________
Martin Prikryl
bilbo6209

Guest


I had it set to update the time stamp initialy, but when this message started coming up I attempted unchecking it to try to clear the message..... If anyone has more info or can tell me what I need to do to resolve teh issue it would be great
bilbo6209

Guest


prikryl wrote:
When synchronizing the timestamp is updated always, disregarding the settings, because the synchronization does not make sense otherwise.


Is there a better way to do this? I set it up with Synchronize to attempt to keep transfer size as low as possible....

Bill
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
bilbo6209 wrote:
Is there a better way to do this?

I do not know of any simple better way.
_________________
Martin Prikryl
bilbo6209

Guest


OK maybe I am missing something....

Using the script

""C:\Program Files\WinSCP\WinSCP.exe" /defaults /synchronize "C:\backup" "/backup/"" I am getting the error.... What do I need to change in the script or in teh settings in teh software to make it so my client isnt getting this message with every backup?

Bill
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
You cannot use synchronize command for files for which the user does not have permissions to update the timestamp.
_________________
Martin Prikryl
bilbo6209

Guest


I have verified teh users have full control over the files on the server, so they should have permission to change the timestamp also.
Guest




I just logged on to the server and verified, all users have read, write, append, and delete permissions for files, and list, make, and delete permissions on folders - including subfolders.

This looks to be all the permissions they would be able to be granted.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License