Topic "Abort and Skip All doesn't work + remember last folder"

Author Message
icefront

Guest


Hi!
I have a bug report and a suggestion:
1. Uploading multiple files, when error occurs during upload, the Abort and Skip All buttons doesn't do anything, simply closes the dialog box and begins with the next file in queue. Skip All may need to skip all files if the same error occurs, Abort may need to clear the queue and stop all transfers.
I started to upload 1000 files, but the ftp was able to receive only 200. I may end clicking 800 Skip's or terminate WinSCP from taks manager
2. Important suggestion: please make an option to simply remember the last folder used, please don't save the last folder for every session. By this, I'll start ALWAYS from the last folder, regardless of where the last session was ended.
2a. When the last used folder cannot be accessed, there is no need to pop up a dialog saying 'c:\bla doesn't exists'. Frequently uploading from removable media makes this annoying dialog continuously appearing.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
icefront wrote:
1. Uploading multiple files, when error occurs during upload, the Abort and Skip All buttons doesn't do anything, simply closes the dialog box and begins with the next file in queue. Skip All may need to skip all files if the same error occurs, Abort may need to clear the queue and stop all transfers.


Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

Quote:
2. Important suggestion: please make an option to simply remember the last folder used, please don't save the last folder for every session. By this, I'll start ALWAYS from the last folder, regardless of where the last session was ended.

I believe that by default WinSCP does not remember the last use directory. You you had to change the default settings. See http://winscp.net/eng/docs/ui_login_directories
_________________
Martin Prikryl
icefront

Guest


Thank you for your answers!

1. Next time it will happen I will send you the log, until that I tell you the exact workflow:
- select multiple files to upload
- press F5 so the copy process starts with the first file, the others are in queue
- for some reason (it doesn't matter what, for example timeout or forbidden ftp access, etc.) the transfer stops, then a dialog pops up with multiple buttons like Skip, Skip all, etc.
Now, here the Abort button does not abort the uploading of the files that are in queue. The uploading starts with the next file, of course again the same error occurs, Abort, then comes the next file, and so on.

2. When the "Remember last used directory" is turned on, the last path of the session is restored. If the path isn't acccessible, a dialog pops up, that the path isn't accessible. This dialog may be useless, when often using removable media it's annoying (you may use a checkbox in the dialog "Don't show this again". Anyway, I understand this behavior.
My recommendation is a switch in the main options that skips the workaround of remembering directories for particular sessions, I mean GLOBALLY remember the last used directory. Otherwise I'm always landing in My Documents, I hate this folder - sorry.
So it's simple:

on main_window_open:
local_directory_panel.initialdir:=inifile.readstring(dir);

on main_window_close:
inifile.writestring(local_directory_panel.initialdir);

That simple.
Take my example: I'm working for microstock agencies. I have around 30 ftp sites set up. I upload the same images/videos for every site. I upload batches of 15-20 images or 4-5 videos of 20-200Mb. I often work from removable media, depending on the place (I have 3 computers) from where I upload. Depending on the other removable media inserted into system, the drive always changes. Now imagine, I start with the first agency, WINSCP says, F:\StockUpload doesn't exists. OK. When I connect to the second agency, WINSCP again says, F:\StockUpload doesn't exists. And so on for all the 20-30 connections. Also, every time I'm in the My Documents directory.
If you understand well, for this kind of work, complicated remembering of last used folders and/or repeated notifications it's just annoying.

Thank you!
As soon I will have a log I will post it here.
Jozsef
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24555
Location: Prague, Czechia
I wasn't able to reproduce the main problem.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License