Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

user123

Re: -nopermissions and -nopreservetime don't avoid perm errors

Psi, Inc wrote:

martin wrote:

matmak wrote:

If -nopermissions and -nopreservetime are supposed to be the fix for this, then those switches themselves need fixing.

What version of WinSCP are you using?


Using Version 4.2.9 Build 938, I was having the same problems until I added the
-nopermissions and -nopreservetime. Worked like a charm after that.


We're using Version 4.0.4 Build 346, and have the same problem. Added -nopermissions and -nopreservetime does not work, error:
File or folder '-nopermissions' does not exist. Any ideas?
Psi, Inc

Re: -nopermissions and -nopreservetime don't avoid perm errors

martin wrote:

matmak wrote:

If -nopermissions and -nopreservetime are supposed to be the fix for this, then those switches themselves need fixing.

What version of WinSCP are you using?


Using Version 4.2.9 Build 938, I was having the same problems until I added the
-nopermissions and -nopreservetime. Worked like a charm after that.
martin

Re: -nopermissions and -nopreservetime don't avoid perm errors

matmak wrote:

If -nopermissions and -nopreservetime are supposed to be the fix for this, then those switches themselves need fixing.

What version of WinSCP are you using?
matmak

-nopermissions and -nopreservetime don't avoid perm errors

If -nopermissions and -nopreservetime are supposed to be the fix for this, then those switches themselves need fixing.

winscp> put -nopermissions -nopreservetime "D:\filestore\etl\data\geography\Region Map Paths.csv" SSRS/
D:Region Map Paths.csv | 1456 KiB | 1789.1 KiB/s | binary | 100%
Upload of file 'Region Map Paths.csv' was successful, but error occurred while setting the permissions and/or timestamp. If the problem persists, turn on 'Ignore permission errors' option.
The server does not support the operation.
Error code: 8
Error message from server (en): The request is not supported.
Request code: 9
(A)bort, (R)etry, (S)kip, Ski(p) all: Abort
winscp>
martin

cdlvj wrote:

I have hit this same error, 1st time in many moons.
What can the client at the server end do to prevent this error?

All our clients have it set correctly except for one.

The file must be owned by the user who is overwritting it. It is not enough to have write permissions to update timestamps and/or set permissions.
cdlvj

I have hit this same error, 1st time in many moons.
What can the client at the server end do to prevent this error?

All our clients have it set correctly except for one.
martin

You can use -nopreservetime and -nopermissions switches to put command.
user33

thanks for respose - but thats not any clearer for me.

This is in a batch with a lot of others which are all working ok, and I really dont want to mess with the rest of them, so I really need to try and do this at script level in the cmd file.

is this possible? if not, can you give me a little example of how you would do this using the method you linked me to? perhaps I will hav to call the ini file for this oen customer?
martin

Re: Ignore permission error - when running from script

This request has been added to tracker.
martin

Re: Ignore permission error - when running from script

Please read FAQ. If that does not help, come back.
user33

Ignore permission error - when running from script

We currently use winscp 4.0.3 in script form to place transmit numerous files to external servers.

This has been running fine, until this morning, when I added a new job.

The error recieved is: Upload of file 'test.csv' was successful, but error occurred while setting the permissions and/or timestamp. If the problem persists, turn on 'Ignore permission errors' option.

I just want to ignore this error, the file goes ok - I just need a switch to use at command line in a script which ignores?

thanks