Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

Guessed

This worked like a champ. Thanks for the post with a solution.

eddo wrote:

in recived this error when I used:
open scp://user@server -privatekey=C:\myprivatekey.pkk
I resolved in this way
open sftp://user@server -privatekey=C:\myprivatekey.pkk
abdo

Re: perfect, il works for me too to access to model SFR (Firepower )

type the command ""chsh -s /bin/bash admin "" and you will get access to firepower with WINSCP.
abdo

perfect, il works for me too to access to model SFR (Firepower )

kujon wrote:

Or you can simply login to Checkpoint GW via SSH and put this command in (in expert mode):
chsh -s /bin/bash admin
;)
hudiefa

Error skipping startup message. Your shell is probably incompatible with the application (BASH is re

some linux machines can't be act as server ( FirePower sensor ) though , you can't use GUI SCP . instead you can copy from the CLI
kujon

Or you can simply login to Checkpoint GW via SSH and put this command in (in expert mode):
chsh -s /bin/bash admin
;)
Noura

Re: checkpoint winSCP

magesh wrote:

you probably in the clish mode thats why its not letting you download in the bash.
login in to the GW under user management > users > unlock the screen from above
for example if you use admin account double click the admin there you can change the shell to /bin/bash

Now goto your winscp and download...!!

There we go..!!


thanks that works for my checkpoint! ;)
martin

Re: My problem was that SSH was selected

MajorRedbeard wrote:

I got this error after importing sites into a new machine, and after failing to log in several times, I checked the settings. I saw it was set to SSH, rather than SFTP, as intended.

Where did you have "SSH" selected? You cannot switch between "SFTP" and "SSH" in WinSCP. Can you show us a screenshot?
MajorRedbeard

My problem was that SSH was selected

I got this error after importing sites into a new machine, and after failing to log in several times, I checked the settings. I saw it was set to SSH, rather than SFTP, as intended.

I switched that and it's working as expected now.
magesh

checkpoint winSCP

you probably in the clish mode thats why its not letting you download in the bash.
login in to the GW under user management > users > unlock the screen from above
for example if you use admin account double click the admin there you can change the shell to /bin/bash

Now goto your winscp and download...!!

There we go..!!
Jack.H

For:
Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended).

I found that our problem was the user was using SCP and sudo, and that sshd required a TTY in order to perform this action.

Thank you! That's exactly the problem I had on Google cloud instance... just need to specify !requiretty in /etc/sudoders
eddo

in recived this error when I used:
open scp://user@server -privatekey=C:\myprivatekey.pkk
I resolved in this way
open sftp://user@server -privatekey=C:\myprivatekey.pkk
Guest3

Error skipping startup message.

For:
Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended).

I found that our problem was the user was using SCP and sudo, and that sshd required a TTY in order to perform this action.
Guest2

martin wrote:

I dont have a clue about this error, it just happens randomly on some machines and I'm too freakin lazy to fix it, or even find out the true reason.


Good Job! You did the right thing.
martin

I dont have a clue about this error, it just happens randomly on some machines and I'm too freakin lazy to fix it, or even find out the true reason.
Guest

prikryl this answer doesnt help at all since there simply IS NO ERROR IN THE LOGs.
you could as well write "I dont have a clue about this error, it just happens randomly on some machines and I'm too freakin lazy to fix it, or even find out the true reason."

thanks......
martin

Re: Error skipping startup message.

See documentation for details about "Error skipping startup message" error.
Guest

Re: Error skipping startup message.

Dork wrote:

I get this error:
Error skipping startup message. Your shell is probably incompatible with the application (Bash is recommended).

Connection has been unexpectedly closed. Server sent command exit status 0.

I then noticed my user was an FTP user and did not have shell access. This took me a while to figure out and I am reporting this here for users in the future. I may still have issues because I have to wait until shell access is granted before I can test this again.


My problem was that the user password on linux machine expired (I have it set up to expire on 90 days) and the shell didn't start.
Dork

Error skipping startup message.

I get this error:
Error skipping startup message. Your shell is probably incompatible with the application (Bash is recommended).

Connection has been unexpectedly closed. Server sent command exit status 0.

I then noticed my user was an FTP user and did not have shell access. This took me a while to figure out and I am reporting this here for users in the future. I may still have issues because I have to wait until shell access is granted before I can test this again.