Post a reply :: Support Forum

Tip: Styles can be applied quickly to selected text.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

lony

done
martin

Re: put <folder> subdir problem

Thanks.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
lony

Re: put <folder> subdir problem

Thank you for your response.

I posted my Logfile under <invalid hyperlink removed by admin>.

Hopefully this could clarify thinks. Just to clear up the script as well, I posted it again.
option confirm off

option transfer binary
open antftp@xdf

cd library
rmdir My
put library\My\

close
martin

Re: put <folder> subdir problem

Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
lony

put <folder> subdir problem

Hello,

I try to upload an folder (Zend Framework) but instead of copying the hole structure WinSCP is only copying the source file in the last subdirectory to the actual remote folder.

The script is basic:
option confirm off

option transfer binary
open foo@xtf
cd library
rmdir My
put library\My\


The result and also the folder structure is shown here:

/library
My
library\My | 0 KiB | 0,0 KiB/s | binary | 0%
library\My\View | 0 KiB | 0,0 KiB/s | binary | 0%
library\My\View\Helper | 0 KiB | 0,0 KiB/s | binary | 0%
AutoRefreshRewriter.php | 2 KiB | 0,0 KiB/s | binary | 100%


Any ideas how I can fix this problem?