Post a reply :: Support Forum

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Tip: Styles can be applied quickly to selected text.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Keep remote directory up to date just broke

Try to fix the problem using the new "Dayligh saving time" switch on Environment tab of login dialog.
Trevor at Turton dotco.za

Re: Keep remote directory up to date just broke

martin wrote:

Try to adjust DST difference with "timezone" offset option on SCP tab of login dialog.
I have this problem as well. It started when Europe switched to Daylight Savings Time. I'm in Johannesburg South Africa and we don't use DST. I have checked the timezone offset option of the SCP tag in the login dialog and it's zero as it should be, I'm connecting to a server in the same area as my client. My guess is that WinSCP is trying to correct for an assumed DST offset when there isn't one.
martin

Re: Keep remote directory up to date just broke

Try to adjust DST difference with "timezone" offset option on SCP tab of login dialog.
kuczora

Keep remote directory up to date just broke

Hello,

I've been using the Keep remote directory up to date option a lot, but a few days ago it just seemed to stop working.

Now *all* the files are uploaded *every* time :-(

The problem started around the change to Daylight Saving here in the UK, and the file timestamps are reported by WinSCP as an hour out. However, this also coincided with my server's IP address being changed and host lookup getting broken for a while, not to mention moving from WinSCP 3.3 to the latest release!

The remote server clock was actually a couple of hours out, so the timestamp isn't being set remotely.

I've tried copying all of the files with Preserve Timstamp set on, but that didn't change anything.

Anyone got any ideas?

Thanks.