Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

anotherusername

My Solution!

After messing around for ages and reading all the useless advice - this is what fixed it for me.
I am using Plesk FTP server with WinSCP connecting on port 21 Passive.
So in SITE settings - Go Advanced - Then FTP under Enviroment.
Change the following commands that used to be set to AUTO
Use MLSD command - On
Force IP for passive - On
Use HOST command - On

Boom then everything worked.
martin

Re: FTP connection and folder listing

Fizzy wrote:

I Am facing this same issue am assuming if it's because the data channel ports 5000-5005 which i have updated the firewall settings which aren't open, It connects to the FTP successfully but does not list the folders under the FTP drive created.

Sorry, I do not understand. Can you try to describe your problem again?
Also, can you retrieve the listing using any other FTP client?
Fizzy

FTP connection and folder listing

Hi,

I Am facing this same issue am assuming if it's because the data channel ports 5000-5005 which i have updated the firewall settings which aren't open, It connects to the FTP successfully but does not list the folders under the FTP drive created.


Timeout detected. (data connection)
Could not retrieve directory listing
Error listing directory '/'.

Appreciate your input in this regard.

Thanks,
Fazil
Charl

WISCP ERROR

Hi All,

This could be caused if the server is in active mode and not in passive mode
martin

Re: Passive Mode

Daniel D wrote:

For example these all ports must be allowed to use passive mode.

Response: 227 Entering Passive Mode (202,234,195,227,219,190).

This is bit confusing. The numbers in the 227 response are not port numbers! Only the 219 and 190 represent a port number 56254 (219 * 256 + 190). The 202,234,195,227 is an IP address. So there's only one port number in the message.
Daniel D

Passive Mode

Try disabling passive mode. Probably not all FTP passive ports are not opened.

For example these all ports must be allowed to use passive mode.

Response: 227 Entering Passive Mode (202,234,195,227,219,190).
TheJjokerR

Re: timeout detected. could not retrieve directory listing

TheJjokerR wrote:

Make sure your server session encryption is the same as your server expects, try different settings and see if something works. No encryption is common to work.


damn didn't mean to bump this, wrong thread, please move to that more recent thread about this.
TheJjokerR

timeout detected. could not retrieve directory listing

Make sure your server session encryption is the same as your server expects, try different settings and see if something works. No encryption is common to work.
ok

Re: For the Progs.

unable to access
user

Re: Solution

find the new one





> 2011-07-13 12:45:14.765 SYST
< 2011-07-13 12:45:14.937 215 UNIX emulated by FileZilla
> 2011-07-13 12:45:14.937 FEAT
< 2011-07-13 12:45:15.125 211-Features:
< 2011-07-13 12:45:15.125 MDTM
< 2011-07-13 12:45:15.125 REST STREAM
< 2011-07-13 12:45:15.125 SIZE
< 2011-07-13 12:45:15.125 MLST type*;size*;modify*;
< 2011-07-13 12:45:15.125 MLSD
< 2011-07-13 12:45:15.125 AUTH SSL
< 2011-07-13 12:45:15.125 AUTH TLS
< 2011-07-13 12:45:15.125 PROT
< 2011-07-13 12:45:15.125 PBSZ
< 2011-07-13 12:45:15.125 UTF8
< 2011-07-13 12:45:15.125 CLNT
< 2011-07-13 12:45:15.125 MFMT
< 2011-07-13 12:45:15.140 211 End
> 2011-07-13 12:45:15.140 PBSZ 0
< 2011-07-13 12:45:15.312 200 PBSZ=0
> 2011-07-13 12:45:15.312 PROT P
< 2011-07-13 12:45:15.484 200 Protection level set to P
. 2011-07-13 12:45:15.484 Connected
. 2011-07-13 12:45:15.484 --------------------------------------------------------------------------
. 2011-07-13 12:45:15.500 Using FTP protocol.
. 2011-07-13 12:45:15.500 Doing startup conversation with host.
> 2011-07-13 12:45:15.515 PWD
< 2011-07-13 12:45:15.687 257 "/" is current directory.
. 2011-07-13 12:45:15.687 Getting current directory name.
. 2011-07-13 12:45:15.703 Retrieving directory listing...
> 2011-07-13 12:45:15.703 TYPE A
< 2011-07-13 12:45:15.875 200 Type set to A
> 2011-07-13 12:45:15.890 PASV
< 2011-07-13 12:45:16.078 227 Entering Passive Mode (172,16,18,6,195,83)
> 2011-07-13 12:45:16.078 LIST -a
< 2011-07-13 12:45:26.609 425 Can't open data connection.
. 2011-07-13 12:45:26.609 Could not retrieve directory listing
. 2011-07-13 12:45:26.625 Retrieving directory listing...
> 2011-07-13 12:45:26.625 TYPE A
< 2011-07-13 12:45:26.796 200 Type set to A
> 2011-07-13 12:45:26.796 PASV
< 2011-07-13 12:45:26.984 227 Entering Passive Mode (172,16,18,6,195,84)
> 2011-07-13 12:45:26.984 LIST
< 2011-07-13 12:45:37.609 425 Can't open data connection.
. 2011-07-13 12:45:37.609 Could not retrieve directory listing
* 2011-07-13 12:45:37.609 (ECommand) Error listing directory '/'.
* 2011-07-13 12:45:37.609 Could not retrieve directory listing
* 2011-07-13 12:45:37.609 Can't open data connection.[/quote]
Guest

Re: Solution

I am getting this error "Can't open data connection". please find the log file below




. 2011-07-13 12:45:13.218 --------------------------------------------------------------------------
. 2011-07-13 12:45:13.218 WinSCP Version 4.3.3 (Build 1340) (OS 5.1.2600 Service Pack 3)
. 2011-07-13 12:45:13.218 Configuration: HKEY_CURRENT_USER\Software\Martin Prikryl\WinSCP 2\
. 2011-07-13 12:45:13.218 Login time: Wednesday, July 13, 2011 12:45:13 PM
. 2011-07-13 12:45:13.218 --------------------------------------------------------------------------
. 2011-07-13 12:45:13.218 Session name: CambridgeAssessment@ftps.vizual.co.uk (Ad-Hoc session)
. 2011-07-13 12:45:13.218 Host name: ftps.vizual.co.uk (Port: 990)
. 2011-07-13 12:45:13.218 User name: CambridgeAssessment (Password: Yes, Key file: No)
. 2011-07-13 12:45:13.218 Tunnel: No
. 2011-07-13 12:45:13.218 Transfer Protocol: FTP
. 2011-07-13 12:45:13.218 Ping type: C, Ping interval: 30 sec; Timeout: 15 sec
. 2011-07-13 12:45:13.218 Proxy: none
. 2011-07-13 12:45:13.218 FTP: FTPS: Implicit SSL/TLS; Passive: Yes [Force IP: No]
. 2011-07-13 12:45:13.218 Local directory: default, Remote directory: home, Update: No, Cache: Yes
. 2011-07-13 12:45:13.218 Cache directory changes: Yes, Permanent: Yes
. 2011-07-13 12:45:13.218 DST mode: 1
. 2011-07-13 12:45:13.218 --------------------------------------------------------------------------
. 2011-07-13 12:45:13.890 Connecting to ftps.vizual.co.uk:990 ...
. 2011-07-13 12:45:14.031 Connected with ftps.vizual.co.uk:990, negotiating SSL connection...
. 2011-07-13 12:45:14.406 SSL connection established. Waiting for welcome message...
< 2011-07-13 12:45:14.406 220 WELCOME TO FTPS.VIZUAL.CO.UK Vizual Business Tools Secure FTP Site ========
> 2011-07-13 12:45:14.406 USER CambridgeAssessment
< 2011-07-13 12:45:14.593 331 Password required for cambridgeassessment
> 2011-07-13 12:45:14.593 PASS **************************
< 2011-07-13 12:45:14.765 230 Logged on
> 2011-07-13 12:45:14.765 SYST
< 2011-07-13 12:45:14.937 215 UNIX emulated by FileZilla
> 2011-07-13 12:45:14.937 FEAT
< 2011-07-13 12:45:15.125 211-Features:
< 2011-07-13 12:45:15.125 MDTM
< 2011-07-13 12:45:15.125 REST STREAM
< 2011-07-13 12:45:15.125 SIZE
< 2011-07-13 12:45:15.125 MLST type*;size*;modify*;
< 2011-07-13 12:45:15.125 MLSD
< 2011-07-13 12:45:15.125 AUTH SSL
< 2011-07-13 12:45:15.125 AUTH TLS
< 2011-07-13 12:45:15.125 PROT
< 2011-07-13 12:45:15.125 PBSZ
< 2011-07-13 12:45:15.125 UTF8
< 2011-07-13 12:45:15.125 CLNT
< 2011-07-13 12:45:15.125 MFMT
< 2011-07-13 12:45:15.140 211 End
> 2011-07-13 12:45:15.140 PBSZ 0
< 2011-07-13 12:45:15.312 200 PBSZ=0
> 2011-07-13 12:45:15.312 PROT P
< 2011-07-13 12:45:15.484 200 Protection level set to P
. 2011-07-13 12:45:15.484 Connected
. 2011-07-13 12:45:15.484 --------------------------------------------------------------------------
. 2011-07-13 12:45:15.500 Using FTP protocol.
. 2011-07-13 12:45:15.500 Doing startup conversation with host.
> 2011-07-13 12:45:15.515 PWD
< 2011-07-13 12:45:15.687 257 "/" is current directory.
. 2011-07-13 12:45:15.687 Getting current directory name.
. 2011-07-13 12:45:15.703 Retrieving directory listing...
> 2011-07-13 12:45:15.703 TYPE A
< 2011-07-13 12:45:15.875 200 Type set to A
> 2011-07-13 12:45:15.890 PASV
< 2011-07-13 12:45:16.078 227 Entering Passive Mode (172,16,18,6,195,83)
> 2011-07-13 12:45:16.078 LIST -a
< 2011-07-13 12:45:26.609 425 Can't open data connection.
. 2011-07-13 12:45:26.609 Could not retrieve directory listing
. 2011-07-13 12:45:26.625 Retrieving directory listing...
> 2011-07-13 12:45:26.625 TYPE A
< 2011-07-13 12:45:26.796 200 Type set to A
> 2011-07-13 12:45:26.796 PASV
< 2011-07-13 12:45:26.984 227 Entering Passive Mode (172,16,18,6,195,84)
> 2011-07-13 12:45:26.984 LIST
< 2011-07-13 12:45:37.609 425 Can't open data connection.
. 2011-07-13 12:45:37.609 Could not retrieve directory listing
* 2011-07-13 12:45:37.609 (ECommand) Error listing directory '/'.
* 2011-07-13 12:45:37.609 Could not retrieve directory listing
* 2011-07-13 12:45:37.609 Can't open data connection.
Hari

Re: For the Progs.

. 2011-07-13 12:45:13.218 --------------------------------------------------------------------------
. 2011-07-13 12:45:13.218 WinSCP Version 4.3.3 (Build 1340) (OS 5.1.2600 Service Pack 3)
. 2011-07-13 12:45:13.218 Configuration: HKEY_CURRENT_USER\Software\Martin Prikryl\WinSCP 2\
. 2011-07-13 12:45:13.218 Login time: Wednesday, July 13, 2011 12:45:13 PM
. 2011-07-13 12:45:13.218 --------------------------------------------------------------------------
. 2011-07-13 12:45:13.218 Session name: CambridgeAssessment@ftps.vizual.co.uk (Ad-Hoc session)
. 2011-07-13 12:45:13.218 Host name: ftps.vizual.co.uk (Port: 990)
. 2011-07-13 12:45:13.218 User name: CambridgeAssessment (Password: Yes, Key file: No)
. 2011-07-13 12:45:13.218 Tunnel: No
. 2011-07-13 12:45:13.218 Transfer Protocol: FTP
. 2011-07-13 12:45:13.218 Ping type: C, Ping interval: 30 sec; Timeout: 15 sec
. 2011-07-13 12:45:13.218 Proxy: none
. 2011-07-13 12:45:13.218 FTP: FTPS: Implicit SSL/TLS; Passive: Yes [Force IP: No]
. 2011-07-13 12:45:13.218 Local directory: default, Remote directory: home, Update: No, Cache: Yes
. 2011-07-13 12:45:13.218 Cache directory changes: Yes, Permanent: Yes
. 2011-07-13 12:45:13.218 DST mode: 1
. 2011-07-13 12:45:13.218 --------------------------------------------------------------------------
. 2011-07-13 12:45:13.890 Connecting to ftps.vizual.co.uk:990 ...
. 2011-07-13 12:45:14.031 Connected with ftps.vizual.co.uk:990, negotiating SSL connection...
. 2011-07-13 12:45:14.406 SSL connection established. Waiting for welcome message...
< 2011-07-13 12:45:14.406 220 WELCOME TO FTPS.VIZUAL.CO.UK Vizual Business Tools Secure FTP Site ========
> 2011-07-13 12:45:14.406 USER CambridgeAssessment
< 2011-07-13 12:45:14.593 331 Password required for cambridgeassessment
> 2011-07-13 12:45:14.593 PASS **************************
< 2011-07-13 12:45:14.765 230 Logged on
> 2011-07-13 12:45:14.765 SYST
< 2011-07-13 12:45:14.937 215 UNIX emulated by FileZilla
> 2011-07-13 12:45:14.937 FEAT
< 2011-07-13 12:45:15.125 211-Features:
< 2011-07-13 12:45:15.125 MDTM
< 2011-07-13 12:45:15.125 REST STREAM
< 2011-07-13 12:45:15.125 SIZE
< 2011-07-13 12:45:15.125 MLST type*;size*;modify*;
< 2011-07-13 12:45:15.125 MLSD
< 2011-07-13 12:45:15.125 AUTH SSL
< 2011-07-13 12:45:15.125 AUTH TLS
< 2011-07-13 12:45:15.125 PROT
< 2011-07-13 12:45:15.125 PBSZ
< 2011-07-13 12:45:15.125 UTF8
< 2011-07-13 12:45:15.125 CLNT
< 2011-07-13 12:45:15.125 MFMT
< 2011-07-13 12:45:15.140 211 End
> 2011-07-13 12:45:15.140 PBSZ 0
< 2011-07-13 12:45:15.312 200 PBSZ=0
> 2011-07-13 12:45:15.312 PROT P
< 2011-07-13 12:45:15.484 200 Protection level set to P
. 2011-07-13 12:45:15.484 Connected
. 2011-07-13 12:45:15.484 --------------------------------------------------------------------------
. 2011-07-13 12:45:15.500 Using FTP protocol.
. 2011-07-13 12:45:15.500 Doing startup conversation with host.
> 2011-07-13 12:45:15.515 PWD
< 2011-07-13 12:45:15.687 257 "/" is current directory.
. 2011-07-13 12:45:15.687 Getting current directory name.
. 2011-07-13 12:45:15.703 Retrieving directory listing...
> 2011-07-13 12:45:15.703 TYPE A
< 2011-07-13 12:45:15.875 200 Type set to A
> 2011-07-13 12:45:15.890 PASV
< 2011-07-13 12:45:16.078 227 Entering Passive Mode (172,16,18,6,195,83)
> 2011-07-13 12:45:16.078 LIST -a
< 2011-07-13 12:45:26.609 425 Can't open data connection.
. 2011-07-13 12:45:26.609 Could not retrieve directory listing
. 2011-07-13 12:45:26.625 Retrieving directory listing...
> 2011-07-13 12:45:26.625 TYPE A
< 2011-07-13 12:45:26.796 200 Type set to A
> 2011-07-13 12:45:26.796 PASV
< 2011-07-13 12:45:26.984 227 Entering Passive Mode (172,16,18,6,195,84)
> 2011-07-13 12:45:26.984 LIST
< 2011-07-13 12:45:37.609 425 Can't open data connection.
. 2011-07-13 12:45:37.609 Could not retrieve directory listing
* 2011-07-13 12:45:37.609 (ECommand) Error listing directory '/'.
* 2011-07-13 12:45:37.609 Could not retrieve directory listing
* 2011-07-13 12:45:37.609 Can't open data connection.
Guest

For the Progs.

Re above, deselecting passive mode,
"Auto" is greyed out, but neither IPv4 nor IPv6 are selected.
What's the story there?
Cheers
Laurie
lmstearn

Timeout

Had a problem with this for years.
Forgive my "layman's" jargon.
Previous dialogues with site Admin & Tech personnel tried to locate a "problem" with my modem. That ceased when exactly the same "problem" arose with a different ADSL2 modem.
Was a problem then with my broadband connection, which used a shared, not dedicated, address at the exchange.
However, the problem was *only* with remote servers run on Microsoft Windows and was dated to a server upgrade ~3.5 years ago.
Other remote servers e.g. Unix didn't care
Once I changed providers, the problem disappeared altogether.
Until now.
It seems to be a connection speed? issue. I have blown my 2 gigabyte allocation and the transfer speed slows to around 7 kbs.
Logging on to the remote Microsoft Windows FTP server I got no timeout message but:
"Could not retrieve directory listing -Can't open data connection"
I deselected passive mode and removed permanent caching and, bingo, got in.
Hope this helps,
Laurie
martin

Re: Solution

Since 4.3 passive mode is default.
grouver

Solution

Hi, this is a bit old however the problem is STILL not solved. It has been getting on my nerves for a while and if there were decent free Windows FTP clients I would have given up on WinSCP a long time ago. Anyway, my rants aside, here is a work around that you might find useful. If you notice, the error message usually suggests that you try passive mode due to inability to open some port. Now there might be any reasons why a port cannot be opened and WinSCP cannot really change that. Nonetheless the software should be able to automatically switch to a passive connection which it currently most definitely does not do.

You have to tick the passive connection box. The way you do this is tick the Advanced options box. Then under Connection tick the passive one. I also selected IPv4 as the internet protocol (might not work in your case) and under Environment>FTP ticked the Force IP ... option. I'd suggest you save all that as a session and reuse the setting next time. If you are editing a saved session make sure that you save.

Hope this helps!
Guest

Re: Log - I hope this is what you wanted

Lauri wrote:

SYST
215 Windows_NT
FEAT
211-FEAT
SIZE
MDTM
211 END
Connected
--------------------------------------------------------------------------
Using FTP protocol.
Doing startup conversation with host.
PWD
257 "/" is current directory.
Getting current directory name.
Retrieving directory listing...
TYPE A
200 Type set to A.
PORT 192,168,1,47,15,209
200 PORT command successful.
LIST -a
150 Opening ASCII mode data connection for /bin/ls.
425 Can't open data connection.
Could not retrieve directory listing
Retrieving directory listing...
TYPE A
200 Type set to A.
PORT 192,168,1,47,15,211
200 PORT command successful.
LIST
150 Opening ASCII mode data connection for /bin/ls.
425 Can't open data connection.
Could not retrieve directory listing
(ECommand) Error listing directory '/'.
Could not retrieve directory listing
Can't open data connection.
Startup conversation with host finished.
TYPE A
200 Type set to A.
TYPE A
200 Type set to A.


Are you using PASSIVE (PASV) connection? If so, you'll need to configure your client accordingly and ensure the proper PASV ports are open on your firewall if you are accessing your FTP server through one. FTP server admin, if other than you, will know the PASSIVE port range.
martin

Re: How do I get the full log

Lauri wrote:

Please explain to me how to get the full log file. Or explain how I can fix this problem.

You cannot fix it. But the problem is tracker already, so it will be resolved eventually.
Lauri

How do I get the full log

Please explain to me how to get the full log file. Or explain how I can fix this problem.
martin

Re: Log - I hope this is what you wanted

You haven't posted full log file, so I cannot tell for sure. But from the IP address I suspect this issue is what you are facing.
Lauri

Log - I hope this is what you wanted

SYST
215 Windows_NT
FEAT
211-FEAT
SIZE
MDTM
211 END
Connected
--------------------------------------------------------------------------
Using FTP protocol.
Doing startup conversation with host.
PWD
257 "/" is current directory.
Getting current directory name.
Retrieving directory listing...
TYPE A
200 Type set to A.
PORT 192,168,1,47,15,209
200 PORT command successful.
LIST -a
150 Opening ASCII mode data connection for /bin/ls.
425 Can't open data connection.
Could not retrieve directory listing
Retrieving directory listing...
TYPE A
200 Type set to A.
PORT 192,168,1,47,15,211
200 PORT command successful.
LIST
150 Opening ASCII mode data connection for /bin/ls.
425 Can't open data connection.
Could not retrieve directory listing
(ECommand) Error listing directory '/'.
Could not retrieve directory listing
Can't open data connection.
Startup conversation with host finished.
TYPE A
200 Type set to A.
TYPE A
200 Type set to A.
martin

Re: still can't get in

Please post a full log file showing failure with passive mode.
Lauri

still can't get in

I'm not sure what you wanted me to see in the documentation. I've uninstalled and re-installed, checked and double checked my settings, host name, passwords, etc., tried both passive and active, and sitll cannot get through to the server. Here's the error message I'm getting now:

Could not retrieve directory listing
Can't open data connection.

It says that it is connected but each time it tries to retrieve the directory it fails. I know that other people are getting through to this server with WinSCP - what is going wrong for me?
Please HELP!
martin

Re: Timeout detected. Could not retrieve directory listing

Please read documentation. If that does not help, come back.
Lauri

Timeout detected. Could not retrieve directory listing

I just downloaded WinSCP. I've tried and tried to get it to connect to the server, but it doesn't work. I've been through the FAQ and all but couldn't find anything to help. this is the error message that I get:

Timeout detected.
Could not retrieve directory listing
Opening ASCII mode data connection for /bin/ls.
Error listing directory '/'.

Can you help me?