Post a reply

Tip: Styles can be applied quickly to selected text.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

ChrisB

Re: Script only waits 9 seconds for a password to be entered

martin wrote:

It's actually not expected that the script requires any user interaction in batch on mode.
That's why there's 10 seconds timeout (it could actually abort straight away).
You can set batch off before the open command and enable the batch on mode only after.


EXACTLY what I needed. Thank you for your help and your product. Donations are on the way!
martin

Re: Script only waits 9 seconds for a password to be entered

It's actually not expected that the script requires any user interaction in batch on mode.
That's why there's 10 seconds timeout (it could actually abort straight away).
You can set batch off before the open command and enable the batch on mode only after.
ChrisB

Script only waits 9 seconds for a password to be entered

Hello,

I have a batch script that uses a connection entry from my ini file that does not have a password set. No matter what value I put in the /timeout setting, the script only waits 9 seconds before failing the connection. Is there any way I can make it wait a little longer for a user to input the password?

Script example:

C:\WinSCP\WinSCP /timeout=60 /command "option batch on" "option confirm off" "open MyFTPSConnection" "ls ""/Home/Test Directory/""" "close" "exit" /log=C:\WinSCP\test_LOG.xml

test_LOG.xml contents:
<?xml version="1.0" encoding="UTF-8"?>
-<session start="2015-05-06T18:34:49.843Z" name="MyFTPSConnection" xmlns="https://winscp.net/schema/session/1.0">
-<failure>
<message>Connection failed.</message>
<message>Using TLSv1.2, cipher TLSv1/SSLv3: AES128-SHA256, 2048 bit RSA</message>
<message>Connection failed.</message>
<message>PASS: parameters are incorrect</message>
</failure>
</session>

Any help is appreciated