Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Tip: Styles can be applied quickly to selected text.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

Gwyn Jones

Thanks Martin,
I e-mailed you a log file. I hope it helps.

Thx.
martin

OK, I've sent you another build.
Gwyn Jones

Thanks, I tried the debug version, but the problem doesn't happen with that!

Tried regular 5.7.5 again and it's still happening.
As I mentioned, the log file from that doesn't really show anything.
martin

Re: Internal editor hangs on closure

Thanks for your report.
I have sent you an email with a debug version of WinSCP to address you have used to register on this forum.
Gwyn Jones

Internal editor hangs on closure

Something strange started happening today.
Open a remote file in the internal editor and close it again. Editor and WinSCP hangs! (I have to kill the process)

I was running an older version 4 WinSCP, so I upgraded to 5.7.5 but the problem still occurs.

It doesn't always happen right away - sometimes on the 2nd or 3rd file opened. I'm not editing or saving anything, just closing the editor window.

I tried session logging, but it's not showing anything unusual. The last entry is just the "Transfer done" message for the file I opened.

(Using Commander interface on Win 7.)