Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Copying files from remote side failed. Transfer complete.

First, please upgrade.
If the problem persists, please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

Copying files from remote side failed. Transfer complete.


Please find below the details:
I have developed a File Transfer solution in Microsoft SQL Server Integration Services.
I first generate a text file with the script with instructions. Then I call the WinSCP executable with the script file.
It copies a zip file i.e generated everyday of the syntax '' from SFTP location to local then copies it to FTP or SFTP destination with a separate script.
WinSCP version: 5.0.8 (Build 2438)
Yesterday the copy from SFTP location to local machine failed. When I tried copying the file manually using the GUI, it gave me the error "Copying files from remote side failed. Transfer complete." even though the file gets copied. Through scripting it is failing because of the dialog box that comes.
Could you please tell me what could be the possible reason. Although, it is happening for yesterday's file only, if I copy day before yesterday's file using GUI, it gets copied without any hassle. I'll give you an update tomorrow if it fails for today's file.
I have tried to include as much information as I can.