Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


SSH & WinSCP Issues - I think I SOLVED it!

SSH & WinSCP Issues - I think I SOLVED it!

CREATE A LOG!!! If not already done so.

It seems there are a lot of people having trouble getting into their iPhone via WinSCP. I also need help & would appreciate any inputthank you.

My phone is an 8GB 3G v3.1.2 and is Pawned with redsn0w-win_0.9beta3 which I have had no problems with other than getting it to work with WinSCP.

I understand or assume, that after Pawning the iPhone, that it might be important to install various app in order for a more successful setup?

After repeatedly failing to get results after googling the time out/connection refused errors & so forth; not to mention the FAQ on the issues with regards to OppenSSH/SBS settings & servicesI started all over again. I note I also tried 2 other computers (win XP & Vista) with the same results and am positive it is all in the setup of the Pawned phonehere is what I have just tried again:

I restored my iPhone Via Itunes (appropriate 64bit version for my Windows 7 laptop) Complete Restore & fresh phone setup
I then pawned again with the appropriate software for my phone redsn0w-win_0.9beta3 & its related firmware file to match my version

Immediately after Pawn install I launched Cydia and updated Essentials (2). Program then restarted Cydia to which I applied 3 changes and phone then reset itself.

From there I installed OppenSSH via All Applications, then hit the back button into All applications again to install SBS Settings which after that I hit the home button and checked the toggle to see 3G/SSH & WiFi enabled.

I uninstalled Winscp 4.2.5 (build 624)/removed all traces I could, restarted computer then reinstalled, then restarted before opening and Im still at a loss as how to get WinSCP going with my phone. Errors included much the same as before (Time out) Unexpected errors and all that whilst attempting fresh conections.

I love having my phone Pawned, but I need to be able to transfer and setup various components of my phone within the Linux/Pawned theme to fully utilize the many amazing applications that having been blowing me and my friends away.

So PLEASEif anyone could advise me or guide me into setting up so I could SSH and install various components I would really appreciate it. Ill try to be as specific on every issue I can be in order to help work out this whole issue on not being able to CONNECT to my phone.

SSH is enabled in the Toggle when I attempt connection (how do you disable edge or do I need too?when I do that I get 3G?)
WiFi is enabled in Toggle (but I am connected Via USBis that right)
I have inputted wifi ip from my iphone and wifi in confirmed working via safari and router settings (mac address done).
Do I need to install services, or is that already installed with redsnow automaticallydoes not SBS do services anywayhow do I verify if I already have something installedcould I not already have services installed and not have it listed in packages & or sources if it is a sub app I am having trouble locating sub apps not do I find the well intended guides listing the priority of installs.

Between all the different versions of software written for the different iphones and firmwaresit gets confusing on what is installed automatically and just makes it all that much harder. Anyways Ill keep trying. Iphone,s wifi ip used as hostnameroot for user & alpine for password. All appropriate services enable on phone and plugged in via usb. Ive tried all the protocols as well. I got the thing working once before when I first started, but for some reason, I had to start reinstalling SSH on my phone and Winscp continually in order to get connected but now that no longer works. As previously stated, I have tried on other computers with xp & vista (mine is win7) with the same errors. WinSCP GUI used.

WTFI just enabled logging for my final attempt to provide all info I couldwent to connect to create a log.AND I GOT INtouch wood I will see if this is just a flukebrbJust closed WinSCP using X, restarted program and logged in successfullynow turning off iphone (not resetting) - disconnecting iPhone from USB and restarting computer, let it load up fully, plug in phone to usb then open with the slider when phone power up & now going to log in via WinSCPOMG!!! Im back innow to try enabling the log on the other two computersbrb

After going from my Lap Top Windows 7 to Win XP then To Vista and everywhere in-between whilst restarting and re-launching WinSCP I did get errors, but they were overcome by allowing the auto reconnect to engage were upon I finally go in. I even got in on one computer without creating a LOG or enabling it??????????? I still think if I had not created a log on my initial lap top, I would still not be getting it. My theory is that when I created a log the first time, it must of somehow changed something on my phone, as before never creating a LOG I was having no chance of connecting with WinSCP, even to the point I RESTORED to factory defaults and pawned from scratchI still had issues even after installing what I thought was some Prioritized waybut when I tried to create log to provide for the WinSCP support team, I seem able to get consistently all of a sudden. Fair enough I get some connection issues, but I think its only because I am changing from one come to the other, which just requires more time before the timeout Limit finishes, which I could change. Must have something to do with finding the key after logging off from one com to another..who knowsI recommend at least trying to create a LOG if you have not done so and have been having trouble like me. Doing so has me working on 3 separate computers now, which just requires extending the time out limit from 15 seconds to MORE time.

Im to confused to go onI hope this helps someone and that its not a flukeso far so good.

Any advice still welcomes

Many Thanks