Does old uploaded file being cached?

Advertisement

Guest
Guest

Does old uploaded file being cached?

Hi,

Can anyone help me solve my problem. I am using a Perl script to upload a file on the server (on my public_html folder). I have used an Active X control to perform this operation where I passed the filename and location where to upload the file. I have incorporated this on my VBA script. I have noticed that the uploading work intermittently. It sometimes uploaded the correct file and sometimes reflected the previously uploaded file which I am not sure if it is being cached.

I am just wondering if old uploaded file is being cached. Although I have checked the Cleanup feature in the preferences and have already clear the cache. :( :cry:

Looking forward for your feedback.

Thanks

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Does old uploaded file being cached?

Sorry, I really do not understand. How do you upload the file? Do you mean that after upload you see the old file in the remote directory? How (in file panel, on web, elsewhere)?
_________________
Martin Prikryl

Reply with quote

Guest
Guest

Re: Does old uploaded file being cached?

martin wrote:

Sorry, I really do not understand. How do you upload the file? Do you mean that after upload you see the old file in the remote directory? How (in file panel, on web, elsewhere)?

I am uploading the file using an ActiveX control (HTTP Wizard) that passes the parameter to my CGI/Perl script located on my WinSCP directory.

Below is the directory where my file is located
/home/user/script -> for cgi/perl scripts
/home/user/public_html -> for uploaded files

I have tried to delete all the uploaded files on my directory and try to upload a new file, to my surprise the filename that was uploaded was one of the file I have deleted on my directory. It is only the filename that is incorrect but details of the uploaded file is correct from my directory.

When I am running on a debug mode in my script the filename I get is correct before it will do the uploading of the file, but once the file was uploaded filename is not correct anymore. This happened irregularly, meaning 6 out of 10.

So I have tried to delete again the files being uploaded and have cleared the cache, this time my script works. I was able to upload the correct filename and details of if as well.

I hope I have explained my scenario, please let me know if still you have some clarification.

Thank you in advance for all the help.

Cheers

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Does old uploaded file being cached?

I still do not understand, sorry :-(

1) Where do you run WinSCP? On your local machine or on some HTTP server via some CGI/Perl scripts?
2) Where do you upload the files from (local machine, the machine where WinSCP is located, i.e. some server)?
3) Do you mean that you run the WinSCP script (anyhow) and it uploads a file that no longer exists?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum