Public key authentication not working in 2.1 beta (#119)

Advertisement

kungfutse
Guest

Public key authentication not working in 2.1 beta (#119)

I'm using Pageant to authenticate using ssh-rsa keys (SSH2). They work like a charm in Putty (0.53b), but here's the log snippet from WinSCP2

. --------------------------------------------------------------------------
. WinSCP Version 2.1.0 (Build 119)
. Login time: 14. tammikuuta 2003 10:53:11
. --------------------------------------------------------------------------
. Session name: ****
. Host name: **** (Port: 22)
. User name: **** (Password: No, Key file: Yes)
. SSH protocol version: 2; Compression: No
. Agent forwarding: Yes; TIS/CryptoCard: No; KI: No
. Ciphers: aes,blowfish,3des,WARN,des; Ssh2DES: No
. Ping interval: 0 sec (0 = off); Timeout: 15 sec
. SSH Bugs: A,A,A,A,A,A,A,
. Proxy: none
. Return code variable: Autodetect; Lookup user groups: Yes
. Shell: default, EOL: 0
. Local directory: default, Remote directory: home, Update: No
. Clear aliases: Yes, Unset nat.vars: Yes
. Alias LS: No, Ign LS warn: Yes, Scp1 Comp: No
. --------------------------------------------------------------------------
. Looking up host "****"
. Connecting to ****
. Server version: SSH-1.99-OpenSSH_3.4p1
. We claim version: SSH-2.0-PuTTY-Local: Jan 12 2003 19:45:16
. Using SSH protocol version 2
. Doing Diffie-Hellman group exchange
. Doing Diffie-Hellman key exchange
. Host key fingerprint is:
. ssh-rsa 1024 17:df:3d:e8:25:1d:bb:63:dd:a1:b1:03:03:85:58:24
. Initialised AES-256 client->server encryption
. Initialised AES-256 server->client encryption
. Reading private key file "****"
. Pageant is running. Requesting keys.
. Pageant has 1 SSH2 keys
. Trying Pageant key #0
. This key matches configured key file
. Key refused
. Unable to authenticate
. Attempt to close connection due to fatal exception:
* Unable to authenticate
. Closing connection.
* (ESshFatal) Unable to authenticate

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: Public key authentication not working in 2.1 beta (#119)

Does anyone have same problem?

It works fine for me. But naturally I will make some more tests. Thanks for letting me know.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: Works very well

icebird2000 wrote:

I have 3 different Linuxboxes, and on all boxes it works very well
With SSH2-RSA? With Pageant?
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: Public key authentication not working in 2.1 beta (#119)

kungfutse wrote:

I'm using Pageant to authenticate using ssh-rsa keys (SSH2). They work like a charm in Putty (0.53b), but here's the log snippet from WinSCP2
...
I've tried all compinations: SSH1/SSH2, RSA/DSA, with/without Pageant. Everything works.

Does public key authentication work for you when you don't use Pageant?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum