WinSCP sometimes does not find partial file

Advertisement

Mylan
Joined:
Posts:
1

WinSCP sometimes does not find partial file

Hi!
Im using WinSCP to download rather large TV recordings from the recording computer to another.
A CoreFTP mini SFTP server is running on the recording computer.
Both machines run Windows 7.
WinSCP version is 5.1.1 build 2735.

WinSCP is regularly started from task scheduler with these parameters:
"/log=c:\log\videolog.log" "/script=C:\Program Files (x86)\WinSCP\ftpscript.txt"

This is the script:
option batch abort
option confirm off
open mynameftp@myname.no-ip.org
get -delete -resume -filemask=|*/ *.* c:\users\keiner\Videos\
exit    

There are no more than some files at a time on the FTP. In the local directory there are more than 100 files. Files are 3 to 4 GB in size.

WinSCP can never transfer one file in one session, but usually resuming works well. Sometimes (I believe after a few days and some files transferred, but maybe anytime), WinSCP does not find the partial file. Or is it being deleted? I dont know.

Here you find a log file:
https://pastebin.com/PcttTbvj

Im not sure what debug level that is as I dont know how to set this from the command line. In the GUI I set it to debug2.
In the log, you will first see an example of a file that was transferred without problems. The next file, it sometimes resumes, sometimes not. So it never finishes and takes forever. The last resume you can see was after a reboot.

I have to add that I also do uploads with WinSCP in parallel. This is strange, but the best and easiest way I found for me to do that was that I made a copy of winscp.exe and called it winscp2.exe. This runs without problems. The upload accesses other folders on both sides. It would be strange if the only problem it would cause for me was this resume thing.

I will be happy to provide more information or other logs if necessary.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: WinSCP sometimes does not find partial file

Thanks for your report.
I have sent you an email with a debug version of WinSCP to address you have used to register on this forum.

Reply with quote

Advertisement

You can post new topics in this forum