D: not accessible ...

Advertisement

Nick2
Guest

D: not accessible ...

Hi, im having a problem. When i connect to my remote host it gets to "Reading remote directory" and then quits with the error "Directory D: not available" or something.

Anyone have any ideas ... I'm not trying to use D: at all.

Nick

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: D: not accessible ...

Nick2 wrote:

Hi, im having a problem. When i connect to my remote host it gets to "Reading remote directory" and then quits with the error "Directory D: not available" or something.

Anyone have any ideas ... I'm not trying to use D: at all.
It is known problem, unfortunatelly I'm still not able to find a cause for it. Do you have D: drive at all. If you do, what it is (HDD, CD)? Do you have C: drive?
_________________
Martin Prikryl

Reply with quote

David
Guest

Re: D: not accessible ...

I have the same problem. XP Pro SP-1, I have A:, D:, and H: drives. A is floppy, D is CD-RW, H is system. If I insert a CD, the application runs normally and defaults to displaying the contents of D.

Reply with quote

Guest

Re: D: not accessible ...

martin wrote:

Nick2 wrote:

Hi, im having a problem. When i connect to my remote host it gets to "Reading remote directory" and then quits with the error "Directory D: not available" or something.

Anyone have any ideas ... I'm not trying to use D: at all.
It is known problem, unfortunatelly I'm still not able to find a cause for it. Do you have D: drive at all. If you do, what it is (HDD, CD)? Do you have C: drive?

I fixed it by disabling daemon tools(virtual cd-rom drive).

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: D: not accessible ...

David wrote:

I have the same problem. XP Pro SP-1, I have A:, D:, and H: drives. A is floppy, D is CD-RW, H is system. If I insert a CD, the application runs normally and defaults to displaying the contents of D.
How did you managed not to have C: drive? I want to simulate this kind of configuration to fix the bug, but I do not know how.
_________________
Martin Prikryl

Reply with quote

Advertisement

David
Guest

Re: D: not accessible ...

martin wrote:

David wrote:

I have the same problem. XP Pro SP-1, I have A:, D:, and H: drives. A is floppy, D is CD-RW, H is system. If I insert a CD, the application runs normally and defaults to displaying the contents of D.
How did you managed not to have C: drive? I want to simulate this kind of configuration to fix the bug, but I do not know how.

Well, I was setting up a new machine for testing. First I installed QNX, then Sun Java Desktop System, then XP. XP automatically created/chose H:, probably becasue of all the partitions. You can probably change your drive letter by going into Computer Management/Disk Management. This may not have the same effect. Make sure you backup your system first.

I also found another workaround yesteday. I was unable to install Symanted AV on my XP partition. One of their articles recommened using the SUBST command.

I opened a command window and typed this in "subst c: h:/", and that fixed my Symantec and WinSCP problem.

David

Reply with quote

Robert
Guest

Re: D: not accessible ...

Got same problem.
(But with my G: (DVD drive/burner)

Just place a CD (or DVD) in the D: and it will work.
I cant get rid of it though. After sending files directly from D: it started.

I too have no C: because of security aspects.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: D: not accessible ...

David wrote:

Well, I was setting up a new machine for testing. First I installed QNX, then Sun Java Desktop System, then XP. XP automatically created/chose H:, probably becasue of all the partitions. You can probably change your drive letter by going into Computer Management/Disk Management. This may not have the same effect. Make sure you backup your system first.
You cannot change drive letter of system and boot drives. While I may install another copy of Windows on D: (to make it system drive), C: still remains boot drive. So I do not know how to simulate your configuration.
_________________
Martin Prikryl

Reply with quote

lgriff
Guest

Re: D: not accessible ...

martin wrote:

David wrote:

Well, I was setting up a new machine for testing. First I installed QNX, then Sun Java Desktop System, then XP. XP automatically created/chose H:, probably becasue of all the partitions. You can probably change your drive letter by going into Computer Management/Disk Management. This may not have the same effect. Make sure you backup your system first.
You cannot change drive letter of system and boot drives. While I may install another copy of Windows on D: (to make it system drive), C: still remains boot drive. So I do not know how to simulate your configuration.

Swap ide ports your drives are connected to. Windows will sometimes assign new drive letters in this situation.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: D: not accessible ...

lgriff wrote:

Swap ide ports your drives are connected to. Windows will sometimes assign new drive letters in this situation.
I cannot make modification in my PC due to warranty. And even if I do I doubt that Windows would run if drive letter of the system drive changes. What I can do is to install new copy of Windows. But I do not know how to force it not to use C: drive.
_________________
Martin Prikryl

Reply with quote

Chriz
Guest

Changing assigned drives

On Win2000/XP you can change the assigned drive letters this way:

1) Right-Click "My Computer"
2) Select "Manage"
3) Go to Storage > Disk Management
4) Right-Click a drive on the list
5) Select "change drive letter..."

I've played a lot with this to properly sort my hard drives and CD-ROMs. I have never tried it on a boot drive though.

Regards
Chriz
chriz at zap dot cl

Reply with quote

Advertisement

You can post new topics in this forum