Connecting to MOVEit Server with SFTP.

Advertisement

mwetmore
Joined:
Posts:
5
Location:
Philadelphia, Pennsylvania US

Connecting to MOVEit Server with SFTP.

After being warned about the embedded URL I removed it and posted #19064 that is more up to date than this one.

https://winscp.net/forum/viewtopic.php?t=15064

WinSCP Version 5.5.3 (Build 4214) (OS 6.1.7601 Service Pack 1 - Windows 7 Ultimate)

https://docs.ipswitch.com/MOVEit/DMZ8.0/Help/User/en/index.htm has winSCP listed as a supported FTP/SSL client but only partially supported as an FTP/SSH client. My application is VB.NET. What follows demonstrates this.

This works on another server but not on MOVEit
.Protocol = WinSCP.Protocol.Sftp
.HostName = My.Settings.Host.Trim
.UserName = My.Settings.SAPUID.Trim
.SshHostKeyFingerprint = My.Settings.HostFingerprint.Trim
.SshPrivateKeyPath = My.Settings.PrivateKeyFile.Trim    

This works on MOVEit but I'd rather not have an exposed password
.Protocol = WinSCP.Protocol.Ftp
.FtpSecure = WinSCP.FtpSecure.Implicit
.HostName = My.Settings.Host.Trim
.UserName = My.Settings.SAPUID.Trim
.Password = My.Settings.Password.Trim    

The server owner is moving from the one that works with SFTP to MOVEit. The private keys are identical on the two servers. The public keys have a PUB extension. Here's the failure point in a Debug 1 log:
. 2015-03-19 13:47:20.735 Offer of public key accepted
! 2015-03-19 13:47:20.735 Authenticating with public key "rsa-key-20140528"
. 2015-03-19 13:47:20.906 Sent public key signature
. 2015-03-19 13:47:20.906 Waiting for the server to continue with the initialization
. 2015-03-19 13:47:20.922 Detected network event
! 2015-03-19 13:47:20.922 Server refused public-key signature despite accepting key!
. 2015-03-19 13:47:20.953 Server refused public-key signature despite accepting key!
. 2015-03-19 13:47:20.953 Prompt (7, SSH password, , &Password: )    
Have you had any contact with Ipswitch regarding this? I mention the PUB extension because (Googling) that may have solved similar problems on other servers. I have asked for it to be removed. That may take a couple of days.

Could it have something to do with the private key permissions? I've had that cause problems.

Thanks in advance.

Michael Wetmore.

Reply with quote

Advertisement

You can post new topics in this forum