File mask bug

Advertisement

HWitche
Donor
Joined:
Posts:
3
Location:
New York

File mask bug

Hi all,

for some weird reasons the "file mask" option "Use same option next time" doesn't work.
I use OS Window 7 and I have the newest version of WinSCP installed.
I click the checkbox, but the program simply doesn't remember my settings.

all the best

Hans

Reply with quote E-mail

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,300
Location:
Prague, Czechia

Re: File mask bug

Thanks for your report.

Can you provide us more details? Step by step instructions to reproduce the bug? Maybe with few screenshots?

Reply with quote

Guest

Dear Martin Prikryl,

I think your program is magnificent and I hope to provide you with the necessary information to tackle the problem:

WinSCP Version 5.7.6.

OS Name Microsoft Windows 7 Professional
Version 6.1.7601 Service Pack 1 Build 7601
System Manufacturer LENOVO
System Model 20DLCTO1WW
System Type x64-based PC
Processor Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz, 2601 Mhz, 2 Core(s), 4 Logical Processor(s)

here my steps:

1) click "Synchronize"
2) click "Transfer Settings" (screenshot)
3) go to "Other: > "File Mask"
4) writting mask into field
5) click OK > close "Transfer Settings"
6) click checkmark "Use same option next time" (screenshot)
7) OK
8) The Task is then flawlessly executed by WinSCP
9) but in the following synchronization, the mask in the "Use same option next time" has disappeared and the checkmark is empty
10) and that means I have to go to step 3 and repeat procedure (screenshot)

best

Hans

Steps.jpg

Reply with quote

H_ans
Guest

"file mask" option "Use same option next time" doesn't work

Got it.

Maybe in a later version it would be possible to enter those masks for each new connection to a specific DIR individually.

Thank you

Hans

Reply with quote

Advertisement

H_ans
Guest

Re: "file mask" option "Use same option next time" doesn't work

martin wrote:

WinSCP supports autoselection rules for transfer settings. So the settings can be host- and directory-specific.

See https://winscp.net/eng/docs/ui_transfer_preset
https://winscp.net/eng/docs/transfer_settings#presets


Thank you Martin,

I see now how it works -- quite hidden and not so obvious -- so please forgive me, for my last question:

for what is the "Use same option next time" in the "Transfer Settings" window then?

best

Hans

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,300
Location:
Prague, Czechia

Re: "file mask" option "Use same option next time" doesn't work

H_ans wrote:

for what is the "Use same option next time" in the "Transfer Settings" window then?
I assume you have meant "Synchronize" dialog.
It's to remember the synchronization options.

Reply with quote

HWitche
Donor
Joined:
Posts:
3
Location:
New York

turn off Optimize connection buffer size

Hi Martin,

I can't find the button or setting to turn off "Optimize connection buffer size".
Is there one or planned in a future version?

all the best
Hans

PS: also I couldn't find a link to post a new topic on the beautifully new designed website, well, it could be me because it's a friday...
[/img]

Description: it seems like easy to do...

Optimize_connection_buffer_size.jpg

Reply with quote E-mail

Advertisement

HWitche
Donor
Joined:
Posts:
3
Location:
New York

thank you! Martin

Got it.

A bit tricky, actually not possible to find, while connected to remote.

Maybe the instruction should be:

1) Disconnect
2) highlight Session
3) click Edit
4) click Advanced
5) etc...

but anyway thank you Martin for your great program!

Reply with quote E-mail

Advertisement

You can post new topics in this forum