Issue registering WinSCPnet.dll - "not a valid .net assembly"

Advertisement

DavidG
Joined:
Posts:
3

Issue registering WinSCPnet.dll - "not a valid .net assembly"

Hi - I have an issue trying to register WinSCPnet.dll for use as COM, and am getting the error that it's not a valid .net assembly. I've checked that I'm calling it from the correct directory, and am associating it with v2.0.50727 .net which is installed on the machine (along with V3 and V3.5). The machine is Win server 2003 so I don't think I can install the V4+ versions of .net framework. I've installed the latest version of WinSCP, and have also tried swapping in the WinSCPnet.dll file in the netstandard2.0 directory of the Automation bundle (though I haven't installed the whole thing, I just did the default install of WinSCP from the download page), but it got the same error. I've also got server admin to try to register the file, but they got the same error, so I don't think access is an issue.
Does anyone have any further ideas of things I could try? I checked for an "unblock" button on the properties of the .dll as mentioned in other posts, but couldn't see one.

Many thanks!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,103
Location:
Prague, Czechia

Re: Issue registering WinSCPnet.dll - "not a valid .net assembly"

WinSCP 5.15 needs .NET framework 4.
If you are stuck with .NET 2, you need to use WinSCP 5.13.9.

Reply with quote

DavidG
Joined:
Posts:
3

Re: Issue registering WinSCPnet.dll - "not a valid .net assembly"

Thanks Martin - do you have a download page for that version? I can only find the latest download. I have seen one on SourceForge etc so can download one from there if needed (and if that is safe!). Thanks again....

Reply with quote

DavidG
Joined:
Posts:
3

Re: Issue registering WinSCPnet.dll - "not a valid .net assembly"

Scrub that - have found it, and it installed and registered successfully.

Many thanks!

Reply with quote

Advertisement

You can post new topics in this forum