Wrong line separator

Advertisement

Tomas
Guest

Wrong line separator

I added into WinSCP this external editor "C:\Program Files\Java\jre1.5.0_06\bin\javaw.exe" -jar "C:\Program Files\jEdit\jedit.jar" !.!
In jEdit I set Default line separator Unix \n.
But when now I edit file by external editor (F4) on remote unix server, WinSCP copies file to my computer, opens jEdit, but line separator DOS/Windows (\r\n).
Is this setting WinSCP or jEdit? I have to end lines \n and this is for me realy big problem. Help, please.
Thank you,
Tomas

Reply with quote

Guest

Re: Wrong line separator

Tomas wrote:

I added into WinSCP this external editor "C:\Program Files\Java\jre1.5.0_06\bin\javaw.exe" -jar "C:\Program Files\jEdit\jedit.jar" !.!
In jEdit I set Default line separator Unix \n.
But when now I edit file by external editor (F4) on remote unix server, WinSCP copies file to my computer, opens jEdit, but line separator DOS/Windows (\r\n).
Is this setting WinSCP or jEdit? I have to end lines \n and this is for me realy big problem. Help, please.
Thank you,
Tomas

Now, I set Transfer mode Binary no Default and downloaded .php scripts have \n line separator. So, it looks, it works fine. But I don't know why it works wrong with Default settings...

Tomas

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,209
Location:
Prague, Czechia

Re: Wrong line separator

Now, I set Transfer mode Binary no Default and downloaded .php scripts have \n line separator. So, it looks, it works fine. But I don't know why it works wrong with Default settings...
Because with the default settings, .js files are transferred in Ascii mode.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum