Tunnel password not updating

Advertisement

marutuk
Joined:
Posts:
6
Location:
United States

Tunnel password not updating

Hello,

At our work we have to connect to our servers using a Tunneled connection and make use of WinSCP feature to store the Tunnel data which is working fine for stored sessions. However we are starting to have issues with the more recent versions of WinSCP where, after upgrading the tunnel password to a new one, where we will receive an Access Denied error from the server.

Could it be that the password does not get updated in the place WinSCP stores it?

Thanks for checking on this.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: Tunnel password not updating

marutuk wrote:

after upgrading the tunnel password to a new one, where we will receive an Access Denied error from the server.
I was not able to reproduce the problem you are describing.
How did you "upgrade the tunnel password to a new one"?

Reply with quote

marutuk
Joined:
Posts:
6
Location:
United States

Re: Tunnel password not updating

martin wrote:

marutuk wrote:

after upgrading the tunnel password to a new one, where we will receive an Access Denied error from the server.
I was not able to reproduce the problem you are describing.
How did you "upgrade the tunnel password to a new one"?
This was done by editing the profile, changing the password for the Tunnel part and saving it.

Oddly enough, after changing this, it doesn't seem to store the updated password as the initial login attempt does fail with an access denied.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: Tunnel password not updating

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl

Reply with quote

marutuk
Joined:
Posts:
6
Location:
United States

Re: Tunnel password not updating

martin wrote:

Please attach a full log file showing the problem (using the latest version of WinSCP).

Thanks, that actually helped pinpoint the issue: as we have to use a secondary token for logging in besides the password, this appears where it goes wrong as it tries to automatically enter the password in the PASSCODE prompt as well:

! 2014-05-21 18:17:11.931 [Tunnel] Using username "XXXXXXXXXXXXXXXXXXX".
. 2014-05-21 18:17:12.025 [Tunnel] Attempting keyboard-interactive authentication
. 2014-05-21 18:17:12.093 [Tunnel] Prompt (6, SSH server authentication, Using keyboard-interactive authentication., Password: )
. 2014-05-21 18:17:12.094 [Tunnel] Using stored password.
. 2014-05-21 18:17:12.233 [Tunnel] Prompt (6, SSH server authentication, Using keyboard-interactive authentication., PASSCODE: )
. 2014-05-21 18:17:12.233 Using remembered password.
. 2014-05-21 18:17:14.887 [Tunnel] Keyboard-interactive authentication failed
! 2014-05-21 18:17:14.887 [Tunnel] Access denied
. 2014-05-21 18:17:14.895 [Tunnel] Attempting keyboard-interactive authentication
. 2014-05-21 18:17:14.962 [Tunnel] Prompt (6, SSH server authentication, Using keyboard-interactive authentication., Password: )
. 2014-05-21 18:17:19.156 [Tunnel] Prompt (6, SSH server authentication, Using keyboard-interactive authentication., PASSCODE: )
. 2014-05-21 18:17:21.726 [Tunnel] Prompt (6, SSH server authentication, , <no prompt>)
. 2014-05-21 18:17:21.726 [Tunnel] Ignoring empty SSH server authentication request
. 2014-05-21 18:17:21.727 [Tunnel] Access granted    

If you need more data, please let me know. This was using version 5.5.3

Reply with quote

marutuk
Joined:
Posts:
6
Location:
United States

Re: Tunnel password not updating

martin wrote:

Thanks for your report.
This bug has been added to the tracker:
https://winscp.net/tracker/show_bug.cgi?id=1176

I'll send you a dev version for testing shortly to your email address.
Thanks. Let me know when it's send, as that email box is a bit full of spam as it's my standard "register for things" email account. :)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Re: Tunnel password not updating

I've sent it already, shortly after my post above.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

marutuk wrote:

Would you be able to resend it, I can't seem to find it in my email.
Resent.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,252
Location:
Prague, Czechia

Thanks for your feedback.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum