Found a bug in ATTR message assembly code (v4)...

Advertisement

James
Guest

Found a bug in ATTR message assembly code (v4)...

Hello,

I found a bug in the ATTR assembly code. The v4 field 'flag' is being handled as an integer, when it should be handled as a byte (only one instance). See /core/SftpFileSystem.cpp, line 2661.

From my testing (and grepping), it appears all of the rest of code performs the correct packet::addByte() operation.

Regards,
James

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,094
Location:
Prague, Czechia

Re: Found a bug in ATTR message assembly code (v4)...

Thanks! Unfortunatelly VanDyke VShell ignores this violation of SFTP, so I have never noticed. This is actually only SFTP server supporting SFTP4 I know. What server are you using?
_________________
Martin Prikryl

Reply with quote

James
Guest

Re: Found a bug in ATTR message assembly code (v4)...

martin wrote:

Thanks! Unfortunatelly VanDyke VShell ignores this violation of SFTP, so I have never noticed. This is actually only SFTP server supporting SFTP4 I know. What server are you using?

My company is working on our own server implementation, www.mocana.com. It's very early for v4, I actually didn't find any other v4 clients beside WinSCP. I will check out the VanDyke client as well.

fyi - I haven't found any other incompatibilities. The client is excellent! Great job!

Thank you,
James

Reply with quote

James
Joined:
Posts:
2

Re: Found a bug in ATTR message assembly code (v4)...

[quote="martin"]Thanks! Unfortunatelly VanDyke VShell ignores this violation of SFTP, so I have never noticed. This is actually only SFTP server supporting SFTP4 I know. What server are you using?[/quote]

Martin,

I am registered with your system. Send me an email, if you would like a copy of our server for your own testing.

Thank you,
James

Reply with quote

Advertisement

You can post new topics in this forum